Toad World® Forums

Login Errorr ORA-01017


#1

I couldn’t find anybody asking/complaining about this issue; thus I am starting this thread. ( or I couldn’t find it?)

Why does it take TOAD over 60 seconds to return with an ORA-01017 error - false login credentials?

So my question is NOT about failing to login, but ONLY about the time it takes to get the error. I sometimes fat-finger or use the wrong password from a different database and as the DBA & developer I have to remember several passwords. I know you can save the passwords, but our password as DBA (a) change frequently for security, (b) bad practice to save passwords.

All ORACLE tools return the error immediately.


#2

For me this error comes back quickly. Is this just a normal database user or do you have any kind of external authentication?


#3

Any type of user DBA/standard user


#4

Hi, have the same issue. With each new version this is getting even worse. Tried Toad 13, the delay is 80 - 90 s …


#5

Have you tried setting any of the timeout parameters in your sqlnet.ora?

Go here and search for TIMEOUT.

docs.oracle.com/…/sqlnet.htm

You can also try a CONNECT_TIMEOUT in tnsnames.ora entries, if you don’t want to set it globally.


#6

This issue does not look like to be Oracle Net problem, but Toad’s.

(Didn’t notice any delay on other applications/utilities using oracle, also, have CONNECT_TIMEOUT = 10)


#7

Hi,
one possible reason for this delay, which was found out with a help of the “Process Monitor” (many thanks to Mark Russinovich for great utils), could be missing file “online_resources.xml” inside the app data folder (C:\Users<user>\AppData\Roaming\Quest Software\Toad for Oracle<XX.YY>\User Files). Toad was also looking for this file at community-downloads.quest.com/…/online_resources.xml so I have downloaded it from there. With this file present the delay was reduced (only about 20s for the first connection attempt and almost no delay for all next attempts).


#8

That file is not installed with Toad. We download it the first time it is needed. It sounds like the machine that you installed Toad on does not have internet access.

If you want Toad to never attempt to access the internet, uninstall it, then reinstall using the MSI file, like this:

RESTRICTIONS=i

Here’s the documentation about that.

https://support.quest.com/technical-documents/toad-for-oracle/13.0/installation-guide/3#Command-