Toad World® Forums

Why does TOAD 12.10.0.30 take so long to report ORA-01017 invalid username/password?


#1

When I enter the correct username/password, my connection goes through and I am doing work within 5 seconds. When I enter an invalid password, the screen hangs for what seems to be ages before displaying the error message. Actual clock time is around 45 seconds. When I spool the output, TOAD knows that the password was wrong in about .047 seconds so it seems like a horribly long time to wait for another chance to enter the correct password. Doing the same good/bad password test in SQL*Plus returns instantly in both cases.

Here is the spool output with appropriate privacy edits applied:


– Timestamp: 10:55:45.005
Connect: SYSTEM@mydb.mydomain.COM


– Session: SYSTEM@mydb.mydomain.COM
– Timestamp: 10:55:45.052
Error: ORA-01017: invalid username/password; logon denied


– Timestamp: 10:56:43.840
Connect: SYSTEM@mydb.mydomain.COM


– Session: SYSTEM@mydb.mydomain.COM
– Timestamp: 10:56:43.902
SELECT version, product, sysdate FROM sys.PRODUCT_COMPONENT_VERSION WHERE UPPER(PRODUCT) LIKE ‘%ORACLE%’;


#2

We don’t add any delay. If there is an error, we post it immediately. My guess in your situation is that the “Connect” command isn’t spooled until it is kicked back from Oracle with the error.

Are SQL*Plus and Toad using the same Oracle client?


#3

Thanks for the reply John. I can see the connect attempt and the error message in the spool window for the whole 45 seconds that I am waiting for the error message to pop up so the messages are being spooled out immediately. Several of my coworkers have reported the same problem since we upgraded to new Windows 10 machines with this newer version of TOAD loaded. Our old Windows 7 machines would display the error message in under 1 second.

I only have Oracle Client 11.2.0.4 loaded on my PC. The old PC used 11.2.0.2 and a previous version of TOAD that I don’t remember. It was probably a 10.x.


#4

I just tried it on windows 10 and for me, it comes back immediately. I tried with Toad 13.0 and 12.10, (both 64 bit) using an 18c client, connecting to a remote 12.2 database.

Can you try the newest Oracle client and see if that solves it? I can try 11.2, but I’ll take me a little while to set that up, as I don’t want to change the W10 testbed that I have now.


#5

I just re-read your message and noticed that you said you get the connection error in the spool sql, but then another 45 seconds to get the dialog. So you’re right, it does not seem to be related to Oracle.

For what it’s worth, I tried it with Windows 10 and Oracle 11.2 client and I got the error dialog quickly.

I don’t see any need for you to try an 18c client, but I’d be interested in knowing if this happens with the Toad 13.0 trial.

Also, can you post (or email to me) the contents of help -> support bundle? you can send to john.dorlon@quest.com


#6

What is your solution about the topic?


#7

I don’t have a solution because I can’t reproduce it.


#8

Can you share the contents of your sqlnet.ora file with us?


#9

It’s not very exciting but here it is:

SQLNET.AUTHENTICATION_SERVICES= (NTS)

NAMES.DIRECTORY_PATH= (TNSNAMES, EZCONNECT)

#10

Thank you for your interest.
We’ ve already came accross with tihs issue. However we couldn’t resolved yet.


#11

If you discover anything, please let us know.


#12

Allright. If I find something different, I will inform you,


#13

Here are some things that I wonder about it

  1. Does it happen on any database?
  2. Does it happen if you try a different Oracle client?
  3. do your coworkers experience it too? If not, can you find something different about their configuration?

#14

For me, this happens on any database. We have “lots” of Oracle instances (exact number is company private info, not to be publicly shared). I would be surprised if this is related to the Oracle Client since the error message shows up in the spool window immediately. All of my coworkers experience the same problem and it started for each of them as they got the new version. Unfortunately, I cannot test exclusively if this is related to Win7 vs Win10 because all of our old Win7 boxes had Toad 10.x and all of our new Win10 boxes have the newer Toad 12.x.

I wonder if it is possibly related to our tnsnames.ora file being exceptionally long to handle all of our instance names?


#15

I’ve put 1000’s of entries in my tnsnames.ora but it didn’t seem to matter.

I’ve looked at our code. There really is very little that happens between receiving the error and displaying the message. WHen you say “spool window” are you talking about spool sql or the separate SQL Tracker app? If SQL Tracker, do you see same timings in Spool SQL? SQL Tracker kind of sits between Toad and Oracle client. Spool SQL is in the same process as Toad.exe.

I don’t think this problem is exclusive to W10…I’ve heard of this problem off and on over the years, before W10 existed.


#16

I don’t think tnsnames.ora is related, but as a test, you could rename that file, then make a direct connection.


#17

I am using the built in TOAD Spool SQL window.


#18

Could this be caused by the fact that our machines are locked down tight by the admins to where we don’t have write permissions on most of the subdirectories where log files may be written? I just confirmed that I cannot create or modify files in the \network\logs or \network\trace directories. Similarly, I cannot edit anything in the …Toad for Oracle 12.10\ClientFiles* subdirectories. Also, my sqlnet.ora and tnsnames.ora files are on a read-only network mount.


#19

Maybe? I can try to lock things down here a bit and see what happens.

Toad only uses the (install folder)\ClientFiles folders when it needs to make a new folder for user files in C:\Users(user name)\AppData\Roaming\Quest Software\Toad for Oracle(version number), so I don’t think that would come into play here.


#20

Do you have anything set in your sqlnet.ora that might result in any client side logging?