Toad World® Forums

Lost outlining


#1

Lost outlining


#2

Curious, what’s the file extension your program?

Also, what do you have set on

Mouse Right Click

Language/Syntax Highlighting?

It should be set to PLSQL


#3

As possibly mentioned before I have seen this when the file name of the tab has
been changed to .txt

On Mon, Nov 8, 2010 at 3:32 PM, McAllister, Michael AU CTR Contractor AETC
AETC/A3IS wrote:

Hi

 

Not sure I’m going to use the right terminology here. But, I have a
particular file for a package body that the IF, CASE, BEGIN, END etc
sections are not being outlined. By outlined I mean the lines connecting the
beginning of the block to the end. If I copy the same code into a new editor
tab it shows up fine. Any idea what could be causing this?

 

Regards,

 

Mike McAllister

Principal Systems Engineer

TKC Global, LLC

Phone: 512 423 7447

Email: michael@pairofsixes.com

#4

Curious, what’s the file extension your program?

The file extension is PKB (package body). Asking this question made me check
other PKB files, and they all have the same problem. This seems to have happened
recently. Possibly since I installed 10.6, but I can’t be 100% sure of
that.

Also, what do you have set on

Mouse Right Click

Language/Syntax Highlighting?

It should be set to PLSQL

Yes, it is set to PL/SQL

Mike
smime.p7s (5.18 KB)


#5

Weird…if it’s set to PLSQL that should activate the correct
parser/highlighting scheme.

Maybe Mike has an idea, otherwise you may want to go ahead and open a ticket
with support.


#6

Out of curiosity, what happens if you select all text and paste it into a new
tab. Are they shown then?


#7

Ignore, I see that you already specified that.


#8

In the options, Editor -> Behaviour, Languages, hit the three dots button beside where it says PL/SQL in the drop down list to open the Language Management dialog. On the General tab, does it still list PKB in the file extensions field?

Kevin.


#9

In the options, Editor -> Behaviour, Languages, hit the three dots button beside
where it says PL/SQL in the drop down list to open the Language Management
dialog. On the General tab, does it still list PKB in the file extensions field?

Yes it does.