Toad World® Forums

Re: Save file file type conundrum

Thanks everyone. I looked in both places, the Tab options and the General File
before I posted but forgot to put that in the question.

This is just a minor annoyance but I was wondering if there was a super-secret
option that I was missing.

The annoyance is that if I’m not paying attention when I save a sql
script, it is saved with the default PL/SQL filetype and the next time I open
it, the PL/SQL editor opens, Navigator and all. So the file open is working as
expected. Just not the file save.

Dan Brevetti

9G411

dbrevetti@mitre.org

703-983-2002

What i sent yesterday did not help?
Right clicking in the editor where you type and clickimg properties? The default
style is highlighted. I’m not at work right now so I can’t look at it.

On Fri, May 6, 2011 at 7:29 AM, Brevetti, Dan wrote:

Thanks everyone.  I looked in both places, the Tab options and the General
File before I posted but forgot to put that in the question.

 

This is just a minor annoyance but I was wondering if there was a
super-secret option that I was missing. 

 

The annoyance is that if I’m not paying attention when I save a sql
script, it is saved with the default PL/SQL filetype and the next time I
open it, the PL/SQL editor opens, Navigator and all.   So the file open is
working as expected.  Just not the file save.

 

Dan Brevetti

9G411

dbrevetti@mitre.org

703-983-2002

Gene L. Bradley Jr.

Software Developer I

Information Systems & Integration

Jackson State University

1400 J R Lynch Street

P.O. Box 17750

Jackson, MS 39217

ph 601.979.1042

fax 601.371.9146

email gbradley@jsums.edu

Ok, I see what Gene is refering to. This is the “language” that is used to parse the syntax of the data in the editor for highlighting. But it did list the SQL filetype. Just to rule out that this was the issue I did the following:

  1. I cloned the PL/SQL language to a new one called SQL.
  2. I deleted the SQL filetype from the list of filetypes for the PL/SQL language.
  3. I saved the PL/SQL definition.
  4. I then edited the newly created SQL language definition and deleted all filetypes except SQL.
  5. I saved the SQL definition.
  6. Exited TOAD.
  7. Restarted TOAD.

Have an open SQL tab. Same result when attempting to do a File Save As… PL/SQL still is the default filetype.

oh gosh darn!!!

I have done nothing o mine since I installed. Actually a funny thing used to
happen. We used to save our scripts as text files for transport to another
system or to send via email (and because we didn’t know any better…
LOL!!!)

It used to annoy me that sql was the default save as type for me(us).

Now the sql default helps and even rescues me because when you have a crash or a
power failure toad will automatically try to save all the .sql types.

I hope you find it. I’ll keep looking… maybe we can compare some other
settings. Maybe Norm can figure it out, (smile) cheers!!!

On Sun, May 8, 2011 at 9:25 AM, dpb0000
wrote:

Ok, I see what Gene is refering to. This is the "language" that is used to
parse the syntax of the data in the editor for highlighting. But it did list
the SQL filetype. Just to rule out that this was the issue I did the
following:
1. I cloned the PL/SQL language to a new one called SQL.
2. I deleted the SQL filetype from the list of filetypes for the PL/SQL
language.
3. I saved the PL/SQL definition.
4. I then edited the newly created SQL language definition and deleted all
filetypes except SQL.
5. I saved the SQL definition.
6. Exited TOAD.
7. Restarted TOAD.

Have an open SQL tab. Same result when attempting to do a File Save As...
PL/SQL still is the default filetype.

I think I have found it. I cant test it until the database comes up. You can set
the default tab style.

On Sun, May 8, 2011 at 9:25 AM, dpb0000
wrote:

Ok, I see what Gene is refering to. This is the "language" that is used to
parse the syntax of the data in the editor for highlighting. But it did list
the SQL filetype. Just to rule out that this was the issue I did the
following:
1. I cloned the PL/SQL language to a new one called SQL.
2. I deleted the SQL filetype from the list of filetypes for the PL/SQL
language.
3. I saved the PL/SQL definition.
4. I then edited the newly created SQL language definition and deleted all
filetypes except SQL.
5. I saved the SQL definition.
6. Exited TOAD.
7. Restarted TOAD.

Have an open SQL tab. Same result when attempting to do a File Save As...
PL/SQL still is the default filetype.

Hi

I tested what I was talking about.

Setting the default tab style to .txt will make the default save type be .txt

Your scripts will run but highlighting of reserved words etc and code grouping
etc. will not happen.

But your initial problem/quandry will be solved, you won’t have to worry
about accidentally saving as a PL/SQL.

On Sun, May 8, 2011 at 9:25 AM, dpb0000
wrote:

Ok, I see what Gene is refering to. This is the "language" that is used to
parse the syntax of the data in the editor for highlighting. But it did list
the SQL filetype. Just to rule out that this was the issue I did the
following:
1. I cloned the PL/SQL language to a new one called SQL.
2. I deleted the SQL filetype from the list of filetypes for the PL/SQL
language.
3. I saved the PL/SQL definition.
4. I then edited the newly created SQL language definition and deleted all
filetypes except SQL.
5. I saved the SQL definition.
6. Exited TOAD.
7. Restarted TOAD.

Have an open SQL tab. Same result when attempting to do a File Save As...
PL/SQL still is the default filetype.

You can always create a new item in the IdeaPond to support a default extension
based on the tab style chosen so that you can have the desired behavior with
syntax highlighting.

Michael