Toad World® Forums

Migrating from ApexSQL Edit

Hello colleagues,

We are ready to shake the dust off our two Toad licenses that we. We have used Toad for some time between Speed SQL IDE and Apex SQL Edit. At that time it was not very convenient for the purposes of SQL development. Now we are forced to use Toad as all other tools are dead. I have checked 6.5 and it looks promising. Just a couple of questions about some of our day-to-day tasks:

  1.  Is there a way to test (executed and rollback) SQL statement in Toad?
    
  2.  Is there a way to have source-controlled project in Toad (or at least a list of SQL scripts)?
    
  3.  Does Toad support SourceGear Vault source control?
    
  4.  Is there a way to map F2 key in editor to “Alter in Editor” action?
    

Best Regards
Anton Kruglov

Hi Anton,

Thanks for using Toad!

Here is the answer for your question:

Yes, you will see a button at the right corner of Toad Status bar named Auto Commit ,the default value is On, if you want to test your SQL ,please
turn it Off, And then you will see the button Commit changes or Rollback(pic 1)

Yes, Please use Version Control Of Toad. (Select Database which you want to control ,right-click, choose version control ,after configuration, you
will see the SQL Script under these database tree list, and you can source control )

No, We don’t support this.

Toad have the way to map shortcut key. You can do it in Option|Environment|Keyboard. But F2 is the default setting to rename object, so you can
reassign another keyboard (pic 2)

Thanks,

Cathy.

Pic 1

Pic 2

Thank you Cathy. I have got another question - is there some setting in toad to improve SQL Intellisense? With this simple query it have stopped working properly after EXISTS:

select * from web_TERMINALS_CURRENT_TRANSLATED t

WHERE t.STATUS <> dbo.cTermStatusDeactivated()

and exists(select * from serv_TS_GPRS g WHERE g.PARENT_ID = t. and g.QOS=11)

I have checked other competitors like SQL Prompt - they worked flawlessly there.

Hi Akrouglov,

We have the code completion settings in Options|Editor|Code Completion, but can’t solve this issue.

I tried this , when I type t.<<---- Code Completion shows up , but it incorrect ,it display the values which we expect should be column name ,right?

Did you got the same situation with me?

Thanks,

Cathy.

It shows:

While it should be:

thank you very much!

I’ve create an issue TSS-711 for it ,We will fix it in the later TSS version.

Cathy.