Toad World® Forums

Mysterious addition to scripts

Hello!
I’m hoping you will help a newbie figure out what is causing my script (“generated” from selecting a table or other object from schema browser and selecting the “script” tab), to have lines that begin with “prompt”. Example: when looking at a materialized view (or a table, MLOG, etc. ), I see the first line is :
Prompt table MLOG$_nameOf;
create table etc.

My coworker, who has worked with Toad a long time, says his TOAD doesn’t add that line. He said he has no idea what setting would cause that. I’ve spent about 10 hours trying to solve it. I am stumped. I tried renaming the toad.ini file to reinstall/set back to “factory defaults” but the line is still there. My coworker and I are on TOAD 11.0.0.116

Does anyone know where it’s coming from? I’ve attached a screen shot. Please let me know if you need additional info.

Thanks.

PromptMystery.png

I found the culprit: In my version (11.0.0.116) at least, if I right click on an object in the left pane (in Schema Browser), then choose "Create Script" from the menu that appears, followed by selecting the "script options tab", and uncheck the box "SQL * Plus 'Prompt' comments", the prompt statements no longer appear in my generated scripts. Here's a screenshot:

I was able to find the answer to my question myself.