Toad World® Forums

Nested Table Edit working only once (14.0.0.462)

When I execute the following query using F9:

SELECT NEW sys.ora_mining_number_nt( 1 ) FROM dual;

a double-click on (DATASET) opens the Nested Table Edit as expected:
image

Closing that popup and reopening displays an empty list instead:
image

Can you reproduce this? Thanks.

Yes, thanks. I'll fix.

Same with cursor

select level rn, cursor (
select level rn from dual
connect by level <= 3
) vals
from dual
connect by level <= 2;

Thanks for the report (and query). This will be fixed in the next beta.

1 Like

My example seems to work now, but I still get the same behavior for tenorios example using CURSOR.

Should both of them be fixed?

I know I said "next beta" but the fix wasn't made in time for 14.0.15.577. It is definitely fixed for the next one. Sorry about that.

1 Like

Opening the same cursor twice still shows an empty list with 14.0.33.607.
Can you confirm that?

The 2nd time you open it, are you opening the cursor from the same cell of the main table? In that case, It's expected to be empty, because the cursor can be fetched only once.

But now you should be able to see the first row's cursor, then the 2nd, etc.

Yes, that's what I tried.

Good enough for me but a warning instead of an empty list might be nice.

Good idea. Thanks for testing it.