Toad World® Forums

Nodes from Toad 6.2 automation script corrupt the Toad 6.3 file

Hi,

I spent almost three hours building an automation script to find that it got corrupted. When I tried to open the script I got a notice that this script was created with a previous version ( which it wasn’t) and asked if I want to convert it to 6.3. When answering yes, I got an empty script.

I had no choice but to start over. As I did I checked every few steps if it was still valid and found the cause for the corruption.

As this script was similar to another one I am using, I copied some nodes from the original one. Although the original one was created in a previous version, it was works well in version 6.3. Copying the nodes to a new automation script somehow caused the corruption.

The nodes I had were setVariable and save select to Editor with Results.

If necssary, I’ll try to upload the relevent files.

Sincerely,

Shimon J.

Hello Shimon,

If you have valid maintenance, can you please create a Service Request?
https://support.quest.com/create-service-request

If not, can you please upload the automation file (script)?

Regards,
Ondrej

Hi,

The one in charge of purchase and support wasn’t at wok today, so I don’t know if we have a support.

Here are the files.
ScriptCreatedInToad6.3AfterCopyingTwoNodes.tas (6.13 KB)

ScriptCreatedInToad6.0AndUpgradedTwice.tas
ScriptCreatedInToad6.0AndUpgradedTwice.tas (6.2 KB)

ScriptCreatedInToad6.3AfterCopyingTwoNodes.tas
ScriptCreatedInToad6.3AfterCopyingTwoNodes.tas (6.13 KB)

The description activity has to be at the top of the script. If it gets moved (accidently) and you reopen the script it looks like there are no activities. The activities are actually in the script and since the file is xml it can be edited manually to fix. We have tried to prevent moving this activity but have not figured out a way to do this.

Thanks a lot, Debbie.

I’ll be careful for this next time.

Shimon