Object reference not set to an instance of an object

Working on creating an automation script and using select to file for loading data to csv and script is failing with the above error after loading 2049 rows. Please suggest a workaround or anyone aware of this issue. Currently using Toad data point 5.5 version.

Welcome to the Toad Data Point forum!

Firstly, weird that you're getting this error message for something as simple as a File-Select task.

  • Are you always erroring out at 2,049 records? (maybe there is a strange character at around row 2050?) TDP's Profiler might give some insight here.
  • What is the total number of rows you're trying to export?
  • Are there many (e.g. hundreds) of columns per row?
  • Are you close to max disk space ? (have to ask)
  • Permissions are there to write to target file?

Also, TDP 6.0 .just. came out this week, so you may want to upgrade and give it another go with the latest version.

Thank you Gary.

I tried loading data from multiple tables to different csv's and both failed at 2049 records. Not sure exactly every process is failing at the same number of records. It is giving the same error.
When i use import wizard only with out using select to file records are processing.
Yes i do have permissions to the target file and i tried multiple locations.
There are only 8 to 9 columns per row
Disc space is not a problem.
I am trying to export 4000 rows in one dataset and 100k in another dataset.