Toad World® Forums

Open/Save problem in TOAD Editor

Hi

When I try to open a file with TOAD Editor, it always try to list \<share>$ first , but I do not have permission there.
I get an error message “Windows cannot access \<share>$. You do not have permission…”

The same happens with “Save As” option. In both cases, after while, I get the directory list and I can continue but most
of the time my TOAD freeze.

What and where should I try?

Thank you and best regards!

P.S.

Oracle 11gR2 on AIX Unix
TOAD 12.1 ( +patch )
Windows XP…

When Toad (any other Windows apps) open a file it tries to place write lock protect, in this case on that directory (I had similar problem with directory that could not be deleted when it was last some file opend in Toad).
Because you are not allowed to write on file system on AIX share, your action failed.

Solution:
Copy file locally or get write permission on that share

Thank you Damir, nice try but I am not interested to do anything with this directory. I just wander, why TOAD is trying to list exactly this directory I had no permission on and how to change the behavior. How and where should I change this and tell TOAD to initially open and list some other directory I have permission on it ?

Regards!

Hi Aci,

Toad for Oracle will attempt to initialize the dialog to the directory of the last file accessed from within Toad. If you’re working from an imaged installation of Toad, it may be referencing this path from the original installation.

The last used directory is stored in your Toad.ini file. Exit Toad and open up this file. Inside, you may find “\<share>$” as the value for the SQL_PATH key. If you remove that value and restart Toad, that should fix your problem.

-John

From: Aci Polajnar [mailto:bounce-acip_296@toadworld.com]
Sent: Friday, February 28, 2014 5:36 AM
To: toadoracle@toadworld.com
Subject: [Toad for Oracle - Discussion Forum] Open/Save problem in TOAD Editor

Open/Save problem in TOAD Editor

Thread created by Aci Polajnar

Hi

When I try to open a file with TOAD Editor, it always try to list \<share>$ first , but I do not have permission there.
I get an error message “Windows cannot access \<share>$. You do not have permission…”

The same happens with “Save As” option. In both cases, after while, I get the directory list and I can continue but most
of the time my TOAD freeze.

What and where should I try?

Thank you and best regards!

P.S.

Oracle 11gR2 on AIX Unix
TOAD 12.1 ( +patch )
Windows XP…

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from Toad for Oracle - General notifications altogether.
Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.

How and where should I change this and tell TOAD to initially open and list some other directory I have permission on it ?

You can’t!

Please refer to this thread which I was pointing.

www.toadworld.com/…/20224.aspx

Cause is the same

:slight_smile:

Brg

Damir

Thank you John, it might help.

Thank you and best regards!