ORA-00904: "OBJECT_TYPE": invalid identifier

In Data Grid after I click on 'Export Dataset' I get the following error: ORA-00904: "OBJECT_TYPE": invalid identifier. I'm running the query from an Oracle db. retrieving data from MSSQL db./table. It appears to be related the fact the data is retrieved via db. link(MS SQL). Doing the same thing locally, i.e. retrieving/exporting dataset from local db/table works OK. Doing the same thing via db. link to an external Oracle db. works OK as well. I simplified the query to just retrieve a count(*) from the MQSQL db/table, but still get the same error! Tried a couple of tables and the outcome is consistent. Any feedback, suggestion is appreciated. Toad version 17.0 patch 1. Thanks.

I have heard of this problem but haven't been able to reproduce it. I do have an idea of what causes it.

Try this:

  1. Shut down Toad
  2. Browse to C:\Users\YOUR_WINDOWS_USER_NAME\AppData\Roaming\Quest Software\Toad for Oracle\17.1\User Files\
  3. Rename the file Variables.dat to Variables.backup
  4. Start Toad and try again

If the problem is gone, please shut down Toad again, zip up your User Files folder, and send it to me at John.Dorlon@quest.com so I can try to reproduce it. If you could also send me a script to create a table that you can reproduce the problem with, that would help. I don't need table data, just the CREATE TABLE statement.

If you don't want to send your entire User Files folder, please at least send the Variables.backup file and table script.

I'll be out of office today and tomorrow but will look at this Monday.