Toad World® Forums

ORA-03214 - autoextend maxsize

I thought this was fixed but still get ORA-03214 when trying to resize a datafile due to the default autoextend maxsize being set to 32TB instead of UNLIMITED. Please see the attached.

I never changed anything because I wasn't sure what the correct fix should have been.

Here is the original thread.

How about just making the default UNLIMITED? Since 32TB results in an error and UNLIMITED (equivalent of 32TBs) succeeds.

For me, it does get UNLIMITED in there.

I decide if it's unlimited based on number of DB blocks.

Select file_name, BYTES, blocks, autoextensible,
nvl(increment_by, 0) increment_by, maxbytes, maxblocks, status, maxblocks, file_id
from sys.dba_data_files
where TABLESPACE_NAME = 'USERS';

For me, MAXBLOCKS=4294967293 (for bigfile tablespace) or 4194302 (smallfile) indicates a datafile that was marked with maxsize unlimited. Can you check that in your DB? Maybe there is another value I need to look for.

The word UNLIMITED works. The 32TB does not work. I have tried this on multiple databases and all fail with ORA-00704 when 32TB is specified for the AUTOEXTEND MAXSIZE .

4294967293 is correct. 32TB will result in 4294967296 blocks. That seems to be the problem with using 32TB instead of UNLIMITED. 32TB results in two many blocks since the maxsize allowed is 32TB - 3 blocks.

1 Like

I am able to make 32T appear in the alter datafile window. I've logged this in our internal bug tracking system and I'll fix for 14.2. It's too late for 14.1.