Toad World® Forums

ORA-12557: TNS: Protocol Adapter not loadable

I have both the 64bit and 32bit Oracle clients installed, our other tools are working fine but when we try using Toad for Oracle we get the ORA-12557 error.

This setup is on Windows 2012 R2, there is no ORACLE_HOME defined as an environment variable, within toad it appears the correct Oracle 32bit home is recognized, is there a way for me to force only toad to leverage the 32bit client in an ini, registry setting, or config file somehow.

Check the “Make this the TOAD default home” checkbox on the login window.

I had already tried that. Still does not connect.

You shouldn’t normally have to do this, but try putting the Oracle Home that you want Toad to use FIRST in your path. Actually, it doesn’t have to be first, but before any other Oracle Home.

I had tried that as well, still no luck.

You mentioned not having an environment variable set for ORACLE_HOME. Have you also looked in the registry for ORACLE_HOME value being set there? HKLM\SOFTWARE\ORACLE and HKLM\SOFTWARE\Wow6432Node\ORACLE.

HKLM\SOFTWARE\ORACLE has the Oracle client information (ORACLE_BASE, ORACLE_HOME, etc.) for the 64bit version that is installed. HKLM\SOFTWARE\Wow6432Node\ORACLE has the client info for the 32bit version.

Have you tried renaming ORACLE_HOME in those locations? There are suggestions online to rename ORACLE_HOME vars and re-test.

ok, so looking at the registry entries I noticed that we were referencing a shortcut as the ORACLE_HOME instead of the actual path. We did this for some other tools to simplify which client to use. Does Toad 12.8 have a problem with referencing shortcuts on windows 2012 R2 ? The reason I ask is we have Toad 12.8 running the same way on Windows 7 without an issue.

I’m pretty sure we’ve never tested that. Can you change it temporarily and let us know if it fixes the problem? If it does, let us know how to set that up.