Toad World® Forums

Invalid ORACLE_HOME error in TOAD13.1.0.78

Team,

I am getting 'Invalid Oracle Home: C:\PRABU\Softwares\WINDOWS.X64_193000_client_home\bin' error when I try to connect to my database using TOAD 13.1.0.78. However, the ORACLE_HOME system variable is not set till bin directory, but it is set as 'C:\PRABU\Softwares\WINDOWS.X64_193000_client_home'. The system variable screenshot is attached. Please help me to resolve this issue. Thank you!

System Variable

Don't add an ORACLE_HOME environment variable.
Add C:\PRABU\Sofwares\WINDOWS.X64_193000_client_home to your system path instead.

Thank you! I have tried removing ORACLE_HOME and also updated the PATH variable without the bin folder. But, my client itself is being shown up in Installed Clients-> Connect Using drop down.

Ok, so is it working now? You may also need to add a TNS_ADMIN environment variable to specify the folder where your tnsnames.ora file is.

I have TNS_ADMIN added already 'C:\PRABU\Softwares\WINDOWS.X64_193000_client_home\network\admin'

Great, so is the problem solved?

No, its still the same issue. I had it added even before posting this topic. But, facing the error.

Are you using 32 or 64 bit Toad?
32 bit Toad requires a 32 bit Oracle client.
64 bit Toad requires a 64 bit Oracle client.

Both my TOAD and Oracle client are 64-bit.

Try an older Oracle client then. Oracle 19.3 client is much newer than Toad 13.1 so they could not have been certified to work together. Remove the 19.3 client and try a 12.1 or 12.2 client instead.

I cannot use another Oracle client since my organization had upgraded it... Can I try to use TOAD 13.3, will that work?

At the beginning of this thread, you said that the error message included "bin".

Is there a bin folder in your Oracle client? If so, move the files from the bin folder to the folder above, then delete the bin folder.

If that is not the problem, then try Toad 13.3.

I tried that option now and getting new error as 'Can't initialize OCI. Error -1'

zip up your instant client folder and email it to me. john.dorlon@quest.com

okay! I will. Before that, I will give a try for 13.3 installation and check once.

I have installed TOAD for Oracle 13.3 and the issue has been resolved in this version. Eventhough the ORACLE_HOME in TOAD is pointing to bin folder [but the environment variable doesn't], the error is not being thrown and I am able to make the connection without any issues. Thank you @JohnDorlon for your time and assiatance!

1 Like