Toad World® Forums

ORA-54013: INSERT operation disallowed on virtual columns


#1

Toad 12.1.0.14, Oracle 11.2.0.3

When export table data (as insert sql) and table has generated column, insert statement failed because toad doesn’t recognize that.

Fix:

Do not generate sql statement for all columns which are generated

For most of other exports this is OK but not in mentioned case…there might be other-haven’t tested.

brg,

Damir Vadas


#2

Look in the “Exclude Columns” dropdown. There is an option for Virtual Columns. It is optional because maybe the column is not virtual in the destination.

From: damir.vadas_531 [mailto:bounce-damirvadas_531@toadworld.com]

Sent: Wednesday, September 04, 2013 10:35 AM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] ORA-54013: INSERT operation disallowed on virtual columns

ORA-54013: INSERT operation disallowed on virtual columns

Thread created by damir.vadas_531

Toad 12.1.0.14, Oracle 11.2.0.3

When export table data (as insert sql) and table has generated column, insert statement failed because toad doesn’t recognize that.

Fix:

Do not generate sql statement for all columns which are generated

For most of other exports this is OK but not in mentioned case…there might be other-haven’t tested.

brg,

Damir Vadas

http://damir-vadas.blogspot.com

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#3

John,

THX for an answer. This could do the this.

Maybe in case of virtual columns this check should be automatically enabled?

Brg,

Damir Vadas

damir-vadas.blogspot.com


#4

That would be ideal, but the tricky part is this:

The default export format is something other than insert statements. So it would probably be annoying to automatically exclude virtual columns in the other
formats. It seems a bad idea to check it or uncheck it as the user changes to/from the insert statement export format, because they may have already made their “exclude columns” selection and don’t want Toad doing them a favor by changing them.

From: damir.vadas_531 [mailto:bounce-damirvadas_531@toadworld.com]

Sent: Wednesday, September 04, 2013 12:06 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] ORA-54013: INSERT operation disallowed on virtual columns

RE: ORA-54013: INSERT operation disallowed on
virtual columns

Reply by damir.vadas_531

John,

THX for an answer.

This could do the this … maybe in case of virtual columns that this check i automatically enabled?

Brg,

Damir Vadas

damir-vadas.blogspot.com

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#5

you’re right…thx