Toad World® Forums

PERAttribute custom property does not appear when customizing forms

I've defined a custom property on PERAttribute (object type 2003) -- and I also tried with PERAttributeOR10 -- but it doesn't appear in "DataField" list when using a "Data" component like DataEdit, or in columns of a DataVirtualGrid whose DataList is set to Entity --> Attributes.

The custom property is set as "Store" and "Editable".
I'm trying to edit the form with "Customize form as ... --> Same package where metamodel is".

This used to work in Toad 5.4 and it works for PERDomain on Toad 6.5.

Hi Tommaso_Sala,

We will fix this problem (TDM-5452).
I bring workaround for you.
You can DataList edit without choosing in list - you can write name of your custom property.

Regards
Petr

Ok, thanks.
I already workarounded it by directly writing the <DataField> tag in the TXG, didn't know I could write directly without choosing in the list.

I also noted that also some native property are missing with regard to Toad 5, don't know if this is intentional. Please check this out:


(the one deleted with red pen is the custom one)

Some of them seemed to be useful for some cases.

Currently there are showing entity properties - this is a bug.

Regards
Petr

Uh ok!

So... waiting for the next version!

I want to report that I also tried the new 7.0 version, but it suffer from all the issues I recently filed.