Toad World® Forums

Customize Form

Hello,

I was using Toad Data modeler 3.6 and I was using scripts and custom forms that were gvien to me by the person in charge before me.

Scripts working perfectly under version 3.6 and I migrated to 4.3. Scripts and forms were stil working. Recently I tested version 5 but my script are working but not the custom forms: it is giving me a lot of error message…

Is there any thing that change between this version that could explain the error ?

I also tested to create a customize form but the customize form as is always in grey. I don’t find how to enable it. Does anyone has an idea to make it work ?

Thanks for your help

Go to options, choose expert mode, restart TDM – now you will be able to customize forms

From: Ilocans [mailto:bounce-Ilocans@toadworld.com]

Sent: Monday, February 17, 2014 3:16 PM

To: tdmscript@toadworld.com

Subject: [Toad Data Modeler - Scripting & Customizations Discussion Forum] Customize Form

Customize Form

Thread created by Ilocans

Hello,

I was using Toad Data modeler 3.6 and I was using scripts and custom forms that were gvien to me by the person in charge before me.

Scripts working perfectly under version 3.6 and I migrated to 4.3. Scripts and forms were stil working. Recently I tested version 5 but my script are working but not the custom forms: it is
giving me a lot of error message…

Is there any thing that change between this version that could explain the error ?

I also tested to create a customize form but the customize form as is always in grey. I don’t find how to enable it. Does anyone has an idea to make it work ?

Thanks for your help

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad Data Modeler - Scripting & Customizations
notifications altogether.

Toad Data Modeler - Scripting & Customizations Discussion Forum

Flag
this post as spam/abuse.

I am already in expert mode.

Customize forms is not in grey but Customize forms as is grey and I cannot use it. I reinstall several times Toad but I cannot find any way to enable this item

THanks

Ok – you are in expert mode. Now open something - e.g. table editor. Chose customize form – brings up IDE where you can redesign the screen as you see fit.
Make some changes – e.g. I added some simple text to the forms. Close the IDE editable version of the form – close in upper right corner. There are my changes now on the screen – i.e. I can see them. Now choose save form to make it permanent. That’s it – you’re
done.

From: Ilocans [mailto:bounce-Ilocans@toadworld.com]

Sent: Monday, February 17, 2014 5:36 PM

To: tdmscript@toadworld.com

Subject: RE: [Toad Data Modeler - Scripting & Customizations Discussion Forum] Customize Form

RE: Customize Form

Reply by Ilocans

I am already in expert mode.

Customize forms is not in grey but Customize forms as is grey and I cannot use it. I reinstall several times Toad but I cannot find any way to enable this item

THanks

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad Data Modeler - Scripting & Customizations
notifications altogether.

Toad Data Modeler - Scripting & Customizations Discussion Forum

Flag
this post as spam/abuse.

Hi,

you write: “Customize forms is not in grey but Customize forms as is grey and I cannot use it.”

From the TDM Help file:
Customize Form - The changes will be saved to your user package My Package.
Customiez Form as - The changes will be saved to another package than My Package. This option is disabled by default. To enable it, select Settings | Options | Expert Mode and clear the Save the definitions to the My Package checkbox.

Is this what you need?

Regards, Vladka