Toad World® Forums

Printing Errors with TOAD 3.4.5.10


#1

I’m having problems with printing with ver 3.4.15.10.

In the attached file you can see that either the app isn’t calculating font widths correctly or there’s some other larger rendering problem.

I can image the design to a jpeg just fine; however, I want to use either PDF or XPS for publication work – plus TOAD is running in an environment where I don’t have direct access to a printer.

I’ve tried fiddling with the fonts, everything has failed.

Any ideas what I might be able to do?

Thanks

toad.png


#2

Hi,

If we understand well, export to image works fine.
We have tested the issue with PDFREDirect that is free and the problem didn’t occur.
Unfortunately, we keep failing to simulate it.
It would help us a lot if you could answer the following questions:

  1. What program for PDF print do you use?
  2. What font (type, size) do you have?
  3. Did you try to change the font? (If so, which + their sizes)
  4. Does the problem occur for all entities or only some of them?
  5. If only for some of them, what do these entities have in common?
  6. Please try to turn off and on the Align option in Format. Does it help?

Thanks for all the information.

We look forward to hearing from you.

Regards,

Vladka + TDM Team


#3

Welcome to the world of PDF conversion - it’s not 100%. Neither the various freeware print drivers nor the online conversion sites do a perfect job. Some are better than others - but they all have short comings. I have used PrimoPDF for a number of years and find it satisfactory. But it too has warts. I just overlook them since conversion generally means some loss of quality regardless of whether it’s TV pictures, music or print outs …


#4

Answers, as follows:

  1. I used Acrobat 9. I’ll try the free one.
  2. I tried a bunch of sizes, 8-14
  3. Yes, I tried times, helvetica and lucida.
  4. All of the entries with long names.
  5. Long names.
  6. Not sure where that option is?

More information: if I do this as an XPS I get basically the same thing (see attached). So that would indicate to me that this is a problem in your print code.

I’m using XP SP3 (in a VMWare VM) if that is helpful.

Scott
toad2.png


#5

Hi,

Thanks a lot. We will check it.

  1. Right-click the workspace | Workspace Format | Entity tab | Align.

Regards,

Vladka


#6

Hello Scott,

Unfortunately, we keep failing to simulate the problem.
Could you please send us the printed PDF? (modeling@quest.com) Thanks.

Please write us:

  1. Your settings of Page Format in TDM (File | Page Format).
  2. In your Adobe PDF, select File | Document Properties | Fonts and check out if it is the same font you selected in TDM.
  3. Click Start | Settings | Printers and Faxes | right-click your printer | Properties | Device Settings tab | click the Font Substitution Table and find the font type you used. Check out whether it’s not substituted by another type.

We are sorry we can’t reproduce the problem and therefore can’t say what causes it.

Thanks for your co-operation.

Regards,

Vladka + TDM Team