Toad World® Forums

Problem creating hererogenuos query


#1

[Microsoft][ODBC Microsoft Access Driver] ODBC–connection to ‘{Microsoft ODBC for Oracle}(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=es64.c076.us.schneider-electric.com)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=cvhdb310.world)))’ failed."

But if I run a query in Access which is linked to an Oracle table, I do not get any error. To test the oracle driver, I did an import and export from Acccess, to oracle; this process use the oracle driver. Import and Export from Access work so I think there is not problem with the oracle driver. I think maybe I have something wrong in my TDA settings, please help.

When I run a query between a table from MS Access connection and a table from Oracle, I get the following error: "


#2

Go to your native oracle connection(Meaning the one you use in TDA under the Oracle type connection). On the Advance tab set the ODBC drive that works for you. By default we try and use the Microsoft ODBC for Oracle driver. However, you may find better results using the one that is bundled in your OCI client.

Debbie


#3

I tried to run the query by selecting different drivers; none of them work. How can I identify which is the driver bunlde with my oracle client?..Thanks


#4

Go to the ODBC Manager of your OS. When you define an ODBC connection the driver that comes with the client would start with “Oracle”. Unless of course you are using an 11G client or an instance client. These did not seem to be bundled with them. You will need to download from Oracle this driver. I have the 11G one and it works fine.

So once you have the driver, make an ODBC connection and use this is TDA. This is only to test that the driver works for you. You should then be able to assign this driver to the native connection as mentioned earlier and hetro queries will work.

Debbie