Toad World® Forums

Problem with Rebuild Multiple Objects


#1

Toad 10.1.1.8 w/DB Admin Module

I went in under ‘Rebuild Multiple Objects’ with the intention of rebuilding
some indexes into a different tablespace. I specified the tablespace on the
‘Storage Clause Adjustments’ / ‘Tablespaces’ tab for All Indexes.

Then clicked the ‘Rebuild Checked Indexes’ arrow. The script ran but the
indexes remained in the original tablespace. I went back and had it just
create the script instead so I could inspect it and I saw that it hadn’t
picked up the new tablespace. I manually changed the tablespace names in
the script and then ran it successfully so there wasn’t any other problem
with moving them.

Regards,
Brian Keegan
Oracle DBA
Farmers Insurance Group

***** PLEASE NOTE ***** This E-Mail/telefax message and any
documents accompanying this transmission may contain privileged
and/or confidential information and is intended solely for the
addressee(s) named above. If you are not the intended
addressee/recipient, you are hereby notified that any use of,
disclosure, copying, distribution, or reliance on the contents of
this E-Mail/telefax information is strictly prohibited and may
result in legal action against you. Please reply to the sender
advising of the error in transmission and immediately
delete/destroy the message and any accompanying documents. Thank
you.*****


#2

This is working fine here….got any additional info? Are you sure you set
the tablespace for indexes and not something else?


#3

[Attachment(s) from brian.keegan@farmersinsurance.com included below]

Hi John.

Interesting, I’ll try again later today and document it and see if it was
pilot error. I’ll post the results.

I thought I was being very careful with it but who knows; probably wouldn’t
be the first time I made a mistake.

Thanks,
Brian

John Dorlon

         t.com> To
         Sent by: "toad@yahoogroups.com"
         toad@yahoogroups.
         com cc

                                                               Subject
         03/11/2010 12:14 RE: [toad] Problem with Rebuild
                                   Multiple Objects

         Please respond to
         toad@yahoogroups.
                com

This is working fine here….got any additional info? Are you sure you set
the tablespace for indexes and not something else?


#4

[Attachment(s) from brian.keegan@farmersinsurance.com included below]

Well, I’ll be keelhauled, the problem was that I set a tablespace for
Indexes but not one for Index Partitions.

I’ll be off for a long walk on the short plank then. Sorry for the false
alarm, aaarrrrrggggg.

–Brian Keegan
Oracle DBA & Disgraced Pirate

John Dorlon

         t.com> To
         Sent by: "toad@yahoogroups.com"
         toad@yahoogroups.
         com cc

                                                               Subject
         03/11/2010 12:14 RE: [toad] Problem with Rebuild
                                   Multiple Objects

         Please respond to
         toad@yahoogroups.
                com

This is working fine here….got any additional info? Are you sure you set
the tablespace for indexes and not something else?


#5

Arrr, go easy on yourself, me hearty! Better a false alarm than a real one
from whar I be sittin’!