Toad World® Forums

Reduce "Limit Grid Fetch" value

I have a particularly intense query. In SQLDeveloper it takes about 25 mins to return 50 rows. There are only just over 500 rows, but it’s taking so long with Toad’s default return of 500 rows that I cancelled the query.

Is there a way to reduce the number of rows returned. I want TOAD to do the actual exporting of the data. I find SQLDeveloper very temperamental.

Before Toad 12, there was an option called “OCI Array Buffer Size” in the options window.

In 12.0 -> 12.6, the option was removed and Toad adjusts it on the fly based on # and sizes of columns.

In the current beta, the option is restored with a settings for Auto/Manual and you can enter the value in “manual” mode.