Toad World® Forums

RTF file collapsed when reporting in Chinese(BIG5) or English


#1

Hi TDM experts -

No matter I select Chinese or English language when reporting, the rpt file collapsed and ms word shows “the file collapsed …”. And the file has been filled with many garbage characters, not the correct Chinese words.
(I type Chinese words, Big5, in the comment of attributes).

P.S. I’ve already downloaded Language packages and extracted in …\packages\user folder.
Regards,

  • Michael

#2

Hi Michael,

We’ve failed to simulate the problem. Please reply to the following questions. Thanks in advance.

  1. What version of TDM do you use?
  2. What is the language version of your MS Windows?
  3. Did you rename the name of the file with the generated report (default name is report.rtf)?
  4. Please write us more information about your model - number of entities, attributes, relationships…
  5. Can you please send us a screenshot where we can see the incorrect characters?

Thanks very much.

Regards,

Vladka + TDM Team


#3

Hi Vladka -

Thank you for your kindness.

  1. I use TDM 3.3.8.11
  2. MS Windows 2000 professional
  3. I use default name.(report.rtf)
  4. Totally, 13 entities, 151attributes, no relationships.
  5. The comments show in HTML report properly, but they show incorrectly in RTP report and break columns format, like the attachment does.
  6. In report options, if I didn’t check “Add Columns Comments and Notes to Details of Talbe” option, the rtf file works properly.

Thanks and Regards,

  • Michael
    2009-06-23_143735.jpeg

#4

Hello Michael,

Thanks for your fast response.
We tested the report generation with Chinese characters - whole report in Chinese and a report in English (with Chinese comments and notes for entities and attributes) on Windows 2000. (Unfortunately, we don’t understand Chinese. We just installed support for Chinese to our computer and wrote some notes to the ERD using the characters.)
When we opened the RTF report in MS Word 2007, it was O.K. The format was correct, there were no broken columns. However, in Wordpad it was broken, it seems Wordpad cannot display it correctly.
You write MS Word shows “the file collapsed …”. What Word version do you use? Please try MS Word 2007. Also, could you please send us a screenshot of the error?
If you could send us the model, it would be fine. We would test it here. Thanks in advance. (If you can, please send it to: modeling@quest.com.)

Anyway, we have found out that some words are not translated (e.g. check constraints). We will fix it in the dictionary. Thanks for your notification. CR # 64 207.

Regards,

Vladka + Dave


#5

Hi Michael,

Thanks for your model. The root of the problem is the path where you save the report. Please do not use unicode characters in the path. Then the problem should be solved.
I’ve just sent you RTF report generated from your model. I just changed the path for the model.

If you have any questions, please write me back. Thanks.

Regards,

Vladka