Runtime Exception when running UnitTests

Hello guys!

I am currently experiencing runtime exceptions whenever I try to run UTPLSQL packages (or sometimes single tests).
They show up while executing a UT package e.g. BEGIN'UT3.SOME_UT_PACKAGE'); END;


The error message is always the same (i.e. its always line 44), not depending on the package executed. I also checked the line 44 of some packages and in all of them you can't have this error. One for example is only declaring a date (not even initializing it).
The UT framework is also out of question because we didn't change anything recently there, only the Toad version.
So I assume the error is somewhere in Toad?

Unfortunately I cannot provide more infos at the moment, the only thing I can do with the dialogue is copy the error message, which is

ORA-06502: PL/SQL: numerischer oder Wertefehler: Zeichenfolgenpuffer zu klein
ORA-06512: in Zeile 44

Hi Kuvick123,

Which version of Toad is this?

Can you turn on Spool SQL to capture the SQL which is causing the error and post it here?


Hello John!

Ah yes, I could have at least stated the Toad version being used. Sorry, I had quite a stressful day.
Toad Version is - the most current as far as I know.

I activated Spool SQL (didn't think of that one either :man_facepalming: ) and ran a unit test suite.
Since the SQL in question seems to do with temporary LOBs and the UT package is working with CLOBS, I also ran a second package that has nothing to do with LOBs and hat the same error.
I've appended both spool files.
I hope this helps?


Spooled SQL UT_NACHMELDEN.sql (24.0 KB)

Do your packages (or does utplsql) create dbms_output with line lengths greater than 32K?

Oh, also, there was a fix in 16.2 beta for multibyte characters with DBMS Output. That could be the problem here.

Can you download the beta and give that a try? Toad for Oracle 16.2 Beta

Keep your current version installed. The beta will install to its own folder. It will copy settings from 16.1, and then each version will have their own copy of settings.


Regarding the DBMS-Output: the UTs dont do that and I am not aware of utplsql doing that.

I will give the Beta a try tomorrow and come back to you asap!

1 Like

Good morning John,

I just installed the current beta and executed a lot of unit test packages. So far the error hasn't occured. Thus I would consider this issue solved? Thanks a lot! :slight_smile:

1 Like