Toad For Oracle - Freezes

Toad Freezes.

Sometimes when double clicking or sometimes just for clicking on the editor.

Using Windows 11
Toad for Oracle:
Database: Oracle Database 19c Enterprise Edition Release - Production
Oracle EBS: 12.2.11
Oracle Client:

Appreciate any help.

Thank you,

It looks like a utPLSQL call is what's causing those hangs.

If you aren't actively using utPLSQL, things will speed up if you uninstall it.

If you click main menu -> Database -> Spool SQL -> Spool to screen, you will see the utplsql calls that are slowing things down.

What did you click/do in Toad to get that 2nd error?

Not sure what I was doing, probably just copying a few lines or may be nothing and it showed up. So, I pulled that as well.

yes, it is running. I see the spool logging.

It hangs even when I try to select a few lines or try to copy a few lines or sometimes for no reason.


My bad, seems like it is not installed.


UTPLSQL is installed. I can tell from your call stack.

try this query to get the utplsql version.

SELECT SUBSTR (ut.version (), 1, 60) FROM DUAL;

Yes, UT does seem to have been installed on our Database.


I would assume that would be used only when the IDE is enabled to use UT,

Toad auto-detects if it is installed and uses it if it is.

Can utplsql be uninstalled or are others using it?

Seems like there is a Test Automation effort and there are using UTPLSQL. Verified with the DBA.

Will moving to an 18c Client help with some of these issues?

No. When I was talking about Oracle client version, I was referring to the OP's bug in the other thread (where queries were hanging).

But - if there is no public synonym for the UT package, then Toad won't find it. I don't know if that will affect your coworkers or not.

It looks like the first Toad version with utPLSQL support was 13.2. So another option is to install 13.1 or older (you wouldn't have to uninstall your current version).

I have heard cases before where utPLSQL is installed by some user, and another user would prefer to ignore it. I can add an option to next version to do that.

Thank You, John,

I will check with the DBA's if we can work on removing the public synonym for UT. With your expertise, would say that UT is causing this issue and resolving that would fix my issue?


No way to install an earlier version of Toad:


I can't say for sure if this will fix all of the problems that you are experiencing. I just know that it will solve the problem that I saw in the freeze log that you posted.

If you contact support, I think they will send you an installer for an old version.

I'll add this to version 17.0.

I wouldn't be very happy if I had to go all the way back to Toad 13.1. :frowning:

1 Like

Thank you, John,

You have been very quick and helpful. I really appreciate your help.

I will reach back you, if I feel I am blocked. For now, I will try to get the package renamed :slight_smile:


Renaming that package will likely be disruptive to others, but maybe dropping the public synonym for it would work.

In any case, I'll have this in beta on Monday so you could get that if you are ok with running beta versions.

I would be happy to help :slight_smile:

I got the public synonym renamed to XXUT and it seemed to have solved the issue. I have tried a bunch of things and now I have asked others too, to let me know if they find the issue resolved.

This is amazing John, something so small could impact as much on our tool we would never imagine. Thank you again for sharing your insights and helping our team. :slight_smile:


I'm happy to hear that helped.

If you have any other Toad problems or suggestions, please let me know.

1 Like