Se cuelga session de TOAD a veces

Buenas tardes,
Solo comentarle que a veces se presenta el problema que una sesion de "TOAD for Oracle" se cuelga o se queda congelado.


Yo siempre uso de 2 a 4 sesiones de Toad abiertas para el desarrollo en 3 pantallas. Las uso con el "workspace" diferentes en cada session.

A veces se cuelga una session o 2 de Toad; no es siempre ...pero me sucede a veces (de 2 a 3 veces a la semana).
No se a que se debe, talvez es por falta de memoria de mi laptop .
Esto me sucede sin importar las versiones de toad.
Se hace mas importante cuando se cuelga y el editor esta sin grabar... asi que pierdo los cambios.

Quería compartir esto.

Toad for Oracle (64b)
windows 10 pro x64
intel(R) core i7-8650u 1.90Ghz 2.11Ghz
Ram: 16gb

Hola Carlos,

Tal vez sucede porque hay mas que uno sesiones de Toad abierto al mismo tiempo. Es posible hay una cuelga cuando Toad quere escribir en un archivo que es en uso por otro Toad.

When you start the 2nd, 3rd, or 4th copy of Toad, start it like this:

Toad.exe /VIRTUAL

This will make that copy of Toad use its own temporary copy of settings. You will see that Toad is running virtually here:


Let me know if that helps. Note, that only the non-virtual Toad will save its setttings to the main settings folder (this includes changes to the workspace).


El problema es que uso varios "Workspace" ...y en cada instancia uso uno distinto porque veo funcionalidades distintas y es común actualizar el "Workspace" porque elimino y agrego nuevos archivos al "Workspace".

Lo ideal es que nos permita ejecutar varias instancias sin que se bloqueen.

John, si continuo ejecutando varias instancias "NO Virtuales" ...que debería tener en cuenta para minimizar los bloqueos ??
...y asi evitar tener que perder lo codificado.

Gracias John !

Hola Carlos,

No estoy seguro que el razón por los bloqueos es que hay multiple Toads. Es solamente un suposicion. Si el "Virtual mode" arreglarlo, entonces voy a tratar de encontrar el archivo que causa el problema.

Puede probarlo solamente durante algunos dias para ver si se ayuda?

Also, a question - in English to make sure I say it right - I think I know the answer to this, but.....when Toad freezes, does it ever unfreeze, or do you have to end-task and start over?



Instancia Virtual:
Si, ya probé ejecutando la 2da instancia "Toad.exe /VIRTUAL" e hice la actualización de archivos para forzar el cambio en el "Workspace" y verifique que No actualiza el "Workspace".

Toad freezes
Nunca se descongela, siempre tengo que matar el proceso por el "administrador de tareas" y para asegurarme de que este todo ok reinicio mi laptop e iniciar todo nuevamente.

Sorry, I think my Spanish was bad. For the virtual instance - the main thing I wanted to know is if it prevents the freezes. If it does, I will try to find out why non-virtual is causing freezes, then fix it.

Here's what you can expect to get saved by the virtual instance:

  1. database changes.
  2. saved files from Toad

Here's what won't be saved in a virtual instance

  1. Changes to settings
  2. changes to the workspace (like maybe, another editor is opened, or you make some change in the editor but don't save it)

Espero que esto es mas claro.

Ok John, voy a probarlo y te aviso como me fue.

Hi Carlos,

I think even if we prevent the freeze, you are still going to have problems with settings being overwritten. Here is why:

Let's stay you start 4 copies of Toad, none of them virtual, so they are all using the same settings.

Toad 1
Toad 2
Toad 3
Toad 4.

They are all using the same Workspaces.dat file, even if you are using a different workspace in each Toad. They all load workspaces.dat when Toad starts.

If you change the workspace in Toad1, then save it, there is no way that Toad 2, 3, or 4 will find out about that change. Then if you change the workspace in Toad2 and save it, you will have overwritten the changes that you made in Toad1. Things will just get worse when you add in Toads 3 and 4. And the same applies to other Toad settings.

Toad was not meant to share settings between multiple copies of Toad. It would be better to run only one copy of Toad with multiple connections. You can use connection colors and this option to help your connections from getting mixed up.

Hi John
Indeed, I imagined that it worked as you indicate, that is why when I instantiate the copies of toad I do it with different "Workspaces" in each copy to avoid those conoccurrence problems and to be able to update each "Workspaces" in its respective different toad copy.

I never load the same "Workspaces" in 2 or more instances when developing.

Sometimes (when I support users) it is necessary to run more copies of toad with the same "Workspaces" that scenario I only use it to run the "Workspaces" files without updating it
(from today I will use "Toad.exe /VIRTUAL" for those special cases).

About the "Current connection only" option, I used it before knowing that I can change the connection quickly. Now I don't use that option anymore because I work faster knowing that I can switch connections quickly (you taught me that another time and it's great !).

John, I am currently using 3 toad instances:

Toad 1 (instance)
Toad 2 (virtual instance)
Toad 3 (virtual instance) far it has not been blocked.
I will continue working and at the end of the day I will tell you how it went.

Thanks John!

1 Like

Hi John,
Today I have worked with 3 toad instances:

Toad 1 (instance)
Toad 2 (virtual instance)
Toad 3 (virtual instance)

...and so far I haven't had any problems or crashes.
I have cut the internet, to cause the disconnection to the databases and force errors, ...but I have not had any problems.
I hit re-connect the connections to the databases and it continued to work smoothly... I even noticed faster!
When I used the NON-virtualized instances I always had problems or it got a bit slower when reconnecting.

Hopefully you can get it to behave like this but with NOT virtualized instances and thus be able to use and update the "Workspaces".

Thanks John!, excellent work!

Ok, I have a different test for Monday.

Maybe we should have done this first. On Monday, don't use the virtual option.

After you start each Toad:

  1. Go to Help > About
  2. Type "freeze" (there is no box to type it into, just type)
  3. A dialog will appear. Check the "enable freeze detection" checkbox, leave the default 15 secs, and click OK

When a freeze happens, wait 15 seconds and then you should see something like this:

When that happens, click where it says "click here". The dialog will change to this:

In the bottom right, check "copy to clipboard" and hit OK.

Then come here and paste the error log that it gives you in the clipboard.

Thanks, y que tenga un buen fin de semana.

Ok John, el lunes lo hare.

Hello John!

I closed all instances of Toad to shut down my laptop and noticed that one virtual instance got stuck.

I click on the instance and nothing is seen.
I put the mouse on the icon in the task bar and make a print screen and I attach it for you to see.



Hello John, since it was blocked, take advantage and run another toad instance and follow the steps you indicated and the screen with detailed information about the blockage was shown.
But the "copy to clipboard" checkbox doesn't work and it didn't copy anything to the clipboard.
What I was able to copy is the following:

toad-informe.txt (2.4 KB)

I clicked on other places to see if the "copy clipboard" worked that way without success...until I hit "restart" and the blocking problem didn't come up again.

I'm going to try to reboot my laptop and re-create the problem to send you a print screen of everything.


I tried many times and I got the box before the report and when I clicked on it the whole instance was closed
...this has been happening to me until one time it showed me the report and when I click on "copy to clipboard" it doesn't copy I had to do screen prints of everything.
I attached the screens.

I hope I can serve you.


Call Stack
(upload://iaAcE7HusKa4vYC80w3uVfk1Ifz.txt) (2.3 KB)



Thanks. I'll take a closer look at it on Monday. If you ever have to do screen prints like that again, the only thing I need is the call stack.

It looks like it was trying to make a connection while loading a workspace, and Toad was waiting for Oracle to make the connection. On the login window of Toad 16.1, there is a "Connect using Oracle client" checkbox. You may have better luck with that unchecked. If you uncheck it, Toad connects to the database directly, without using your Oracle client.

Hi John,
Excuse my ignorance, but if I uncheck the option "Connect using Oracle client" ...with what version of the client will the connection to the database be made?
..will it be the same version of the database server??

I say this because there are functionalities, commands that work or not depending on the compatibility of the client versions vs. the database version.

We don’t use any client in this case. We connect to the server without a client. That’s the biggest benefit of the No-client option. It can connect to any database version- 7.3 through 21c.

1 Like