Toad World® Forums

Server did not respond within the specified timeout interval

I am using TDP 3.2.0.916. I am using the Automation portion and I’m getting this error occasionally, even with queries I know work : “Server did not respond within the specified timeout interval”, which makes the task fail. Is there any setting I can change in TDP that would stop that error or is that something on the database end? Thanks.

You are actually getting this as an error in the Automation log? Can you post this, I would like to review.

There are some options under Database | Timeouts that you could adjust to see if this makes a difference.

Debbie

Hi Debbie
here is the automation log for yesterday, thanks for looking at it.
automation_log.log (4.66 KB)

How large is the UTIL_LTE_LU_ENB_RRC_CONN table?
When you have one of these errors can you execute the delete statement in the editor. I want to see if you get the same error there also.

What database type is this? SQL Server perhaps?

Debbie

Maybe 30k rows, so it’s not a big table. And yes, I can execute it in the editor with no problems. It is an oracle database.

Any update on this? My automations are failing consistently now with this error, even on other databases and tables. The automation portion of the tool is becoming kind of unusable for me.

I tried reproducing this but could not. This really looks like we are trying to get a connection and we are timing out before we get the connection opened. Please go to the Options | Database | Timeouts and set all of these to 0. This is unlimited. And see if this makes a change.

Debbie

I will test it out and let you know, thanks.