Toad World® Forums

SET DEFINE OFF no longer working


#1

A couple of us are using TOAD v10 while the rest of the company is using TOAD v9. I am trying to insert a row into a table and some of the string literals have an underscore (like “Mark_Adon”). I can use the SET DEFINE OFF in conjunction with my insert and everything works fine in v9 when I SelectAll and hit F9 but does not work on my v10. The message I get is “ORA-00922: missing or invalid option”.

I did some searching on my own and found a suggestion to right-clich the editor window then check or uncheck the Prompt for Substitution Variables option but it fails wither way.

Any ideas?


#2

SET DEFINE OFF is a script function so you need to use F5, not F9 to execute.

From: Doug Horton [mailto:bounce-Doug_Horton@toadworld.com]

Sent: Thursday, August 01, 2013 12:38 PM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] SET DEFINE OFF no longer working

SET DEFINE OFF no longer working

Thread created by Doug Horton

A couple of us are using TOAD v10 while the rest of the company is using TOAD v9. I am trying to insert a row into a table and some of the string literals have an underscore (like “Mark_Adon”).
I can use the SET DEFINE OFF in conjunction with my insert and everything works fine in v9 when I SelectAll and hit F9 but does not work on my v10. The message I get is “ORA-00922: missing or invalid option”.

I did some searching on my own and found a suggestion to right-clich the editor window then check or uncheck the Prompt for Substitution Variables option but it fails wither way.

Any ideas?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#3

SET DEFINE is a SQLPlus command and must be executed with the script engine (F5). F9 executes single statements only and does not handle SQLPlus.

Michael

On 08/01/2013 12:38 PM, Doug Horton wrote:

SET DEFINE OFF no longer working

Thread created by Doug Horton
A couple of us are using TOAD v10 while the rest of the company is using TOAD v9. I am trying to insert a row into a table and some of the string literals have an underscore (like “Mark_Adon”). I can use the SET DEFINE OFF in conjunction with my insert
and everything works fine in v9 when I SelectAll and hit F9 but does not work on my v10. The message I get is “ORA-00922: missing or invalid option”.

I did some searching on my own and found a suggestion to right-clich the editor window then check or uncheck the Prompt for Substitution Variables option but it fails wither way.

Any ideas?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#4

When running a script using F5 you are still prompted for variables. So it is not the same as SQL*Plus SET DEFINE OFF.


#5

Please provide an example. When I run the following as script I am prompted for the first variable. The second returns ORA error. In SQL*Plus the behavior is
nearly identical although it’s an SP2-0552 error that is raised instead.

select
&var from dual;

SET
DEFINE
OFF

select &var
from dual;

From: jen.davis [mailto:bounce-jendavis@toadworld.com]

Sent: Wednesday, January 29, 2014 9:59 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] SET DEFINE OFF no longer working

RE: SET DEFINE OFF no longer working

Reply by jen.davis

When running a script using F5 you are still prompted for variables. So it is not the same as SQL*Plus SET DEFINE OFF.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


No virus found in this message.

Checked by AVG - www.avg.com

Version: 2014.0.4259 / Virus Database: 3681/7041 - Release Date: 01/28/14