Toad World® Forums

setting TOAD Editor window size - ARRG!

(ARGG! it’s Friday)

TOAD 12.0.0.61

I have it set so that when I connect to a schema, the Browser and editor windows are open.

When I go to the Editor window, the SQL Editor window portion is maximized and the defaulted DataGrid is minimized. Even if I do a query, the Data Grid is minimized.

I move up the data grid window to about 1/4 of the screen but cant figure out how to get it to “stick”. I cant see it in options, so it must be something super easy that I’m missing.

How / What can I do to fix the DataGrid window size?

There are a couple different things you could do to get your desktop to “stick”. To the right of the “desktop” dropdown on the Editor toolbar there is a save
desktop button. This will save the state of the desktop that is selected in that dropdown (e.g. SQL, PLSQL). You can also go to options > Toolbars/Menus > Toolbars and check “Auto-save current desktop”. This way every time you close an editor tab the current
state of your desktop will be saved.

From: gerald.novak [mailto:bounce-geraldnovak@toadworld.com]

Sent: Friday, February 14, 2014 10:09 AM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] setting TOAD Editor window size - ARRG!

setting TOAD Editor window size - ARRG!

Thread created by gerald.novak

(ARGG! it’s Friday)

TOAD 12.0.0.61

I have it set so that when I connect to a schema, the Browser and editor windows are open.

When I go to the Editor window, the SQL Editor window portion is maximized and the defaulted DataGrid is minimized. Even if I do a query, the Data Grid is minimized.

I move up the data grid window to about 1/4 of the screen but cant figure out how to get it to “stick”. I cant see it in options, so it must be something super easy that I’m missing.

How / What can I do to fix the DataGrid window size?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

I dont see the Desktop Dropdown, so I tried the Options method.

It was already checked.

I hit Apply/OK sized my editor window, closed the tab. opened a new tab and it stuck there.

I then dropped the connection, reopened the connection and went to the editor . Nope, it was minimized there. I’m trying to have it open up with the appropriate size when I start a connection.

Desktop dropdown. On Edtior toolbar.

If you don’t see it, rt-click on the toolbar and make sure “Desktop” is checked. You can also restore your desktop to the default state. Click the dropdown
arrow on the save desktop button (shown in screenshot to the right of the dropdown) and select the restore option.

From: gerald.novak [mailto:bounce-geraldnovak@toadworld.com]

Sent: Friday, February 14, 2014 11:05 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] setting TOAD Editor window size - ARRG!

RE: setting TOAD Editor window size - ARRG!

Reply by gerald.novak

I dont see the Desktop Dropdown, so I tried the Options method.

It was already checked.

I hit Apply/OK sized my editor window, closed the tab. opened a new tab and it stuck there.

I then dropped the connection, reopened the connection and went to the editor . Nope, it was minimized there. I’m trying to have it open up with the appropriate size when I start a connection.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


No virus found in this message.

Checked by AVG - www.avg.com

Version: 2014.0.4259 / Virus Database: 3697/7088 - Release Date: 02/12/14

Found the save desktop. Saved it as default. Replace? Yes!

Close connection (other connections remain open).

Open connection and …nope, the datagrid is still not where I set it

So when you “save it as default” does that mean you named it “default”? Or did you overwrite SQL or PLSQL desktop?

From: gerald.novak [mailto:bounce-geraldnovak@toadworld.com]

Sent: Friday, February 14, 2014 12:14 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] setting TOAD Editor window size - ARRG!

RE: setting TOAD Editor window size - ARRG!

Reply by gerald.novak

Found the save desktop. Saved it as default. Replace? Yes!

Close connection (other connections remain open).

Open connection and …nope, the datagrid is still not where I set it

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

If you have other editor open and the global option to auto save desktops then the last closed Editor will probably overwrite the desktop. Let’s do this to
make it as simple as possible.

Start Toad.

Do not make any connections. Close any connections/Editors that were automatically made when starting.

Open an Editor (w/o connection).

Configure and save your desktop, or restore the default one, etc. Make sure you give it the same name that was already there. “SQL” or “PL/SQL” by
default.

Now make your connections and open Editors. Is it correct?

From: gerald.novak [mailto:bounce-geraldnovak@toadworld.com]

Sent: Friday, February 14, 2014 12:14 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] setting TOAD Editor window size - ARRG!

RE: setting TOAD Editor window size - ARRG!

Reply by gerald.novak

Found the save desktop. Saved it as default. Replace? Yes!

Close connection (other connections remain open).

Open connection and …nope, the datagrid is still not where I set it

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


No virus found in this message.

Checked by AVG - www.avg.com

Version: 2014.0.4259 / Virus Database: 3697/7088 - Release Date: 02/12/14

Brad - when I save the desktop it asks for a name. The selected (and only) name is “”. That’s what I use

Mike - followed your steps. When I open, configure and save then close and open without a connection, the data grid is still minimized.

But I think I found it (and dont understand). In TOAD options, I had auto open, save size and save position for the EDITOR. When I unchecked size and position, it works.

Doesnt make sense to me though.

Strange. When I click the button to save my Editor desktop, it defaults to the name of the current desktop I’m using, either SQL or PLSQL. Are you sure you’re
clicking in the Editor toolbar and not Toad’s main toolbar? Which version of Toad are you running?

The windows options that save size and position should have no affect on the Editor tab position.

From: gerald.novak [mailto:bounce-geraldnovak@toadworld.com]

Sent: Monday, February 17, 2014 9:52 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] setting TOAD Editor window size - ARRG!

RE: setting TOAD Editor window size - ARRG!

Reply by gerald.novak

Brad - when I save the desktop it asks for a name. The selected (and only) name is “”. That’s what I use

Mike - followed your steps. When I open, configure and save then close and open without a connection, the data grid is still minimized.

But I think I found it (and dont understand). In TOAD options, I had auto open, save size and save position for the EDITOR. When I unchecked size and position, it works.

Doesnt make sense to me though.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

The selected (and only) name is “”. That’s what I use

Un-maximize your editor. is the name of the main Toad desktop. It sounds like you are using the desktop control for the main Toad window and not for the Editor. When a child form is maximized its toolbar is merged with the main Toad menu. In this
screenshot the desktop controls in red are for the main Toad toolbar. The Editor’s is in green.

On 02/17/2014 09:51 AM, gerald.novak wrote:

RE: setting TOAD Editor window size - ARRG!

Reply by gerald.novak
Brad - when I save the desktop it asks for a name. The selected (and only) name is “”. That’s what I use

Mike - followed your steps. When I open, configure and save then close and open without a connection, the data grid is still minimized.

But I think I found it (and dont understand). In TOAD options, I had auto open, save size and save position for the EDITOR. When I unchecked size and position, it works.

Doesnt make sense to me though.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


No virus found in this message.

Checked by AVG - www.avg.com

Version: 2014.0.4259 / Virus Database: 3697/7088 - Release Date: 02/12/14

Ugh. My screenshot was stripped it seems. On your default Editor toolbar the desktop controls are just to the right of the Code Analysis rule set dropdown which has the text “Top 20” in it. If you’re not seeing it and don’t want to mess around with toolbar
customizations to get it back then you can break out the sledgehammer. Close Toad, delete \User Files*.lay files, start Toad. All desktops will be back to their default layout.

Michael

On 02/17/2014 10:39 AM, Michael Staszewski wrote:

Re: setting TOAD Editor window size - ARRG!

Reply by Michael Staszewski

The selected (and only) name is “”. That’s what I use

Un-maximize your editor. is the name of the main Toad desktop. It sounds like you are using the desktop control for the main Toad window and not for the Editor. When a child form is maximized its toolbar is merged with the main Toad menu. In this
screenshot the desktop controls in red are for the main Toad toolbar. The Editor’s is in green.

On 02/17/2014 09:51 AM, gerald.novak wrote:

RE: setting TOAD Editor window size - ARRG!

Reply by gerald.novak
Brad - when I save the desktop it asks for a name. The selected (and only) name is “”. That’s what I use

Mike - followed your steps. When I open, configure and save then close and open without a connection, the data grid is still minimized.

But I think I found it (and dont understand). In TOAD options, I had auto open, save size and save position for the EDITOR. When I unchecked size and position, it works.

Doesnt make sense to me though.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


No virus found in this message.

Checked by AVG - www.avg.com

Version: 2014.0.4259 / Virus Database: 3697/7088 - Release Date: 02/12/14

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


No virus found in this message.

Checked by AVG - www.avg.com

Version: 2014.0.4259 / Virus Database: 3697/7088 - Release Date: 02/12/14

Ugh. My screenshot was stripped it seems

Same here

From: Michael Staszewski [mailto:bounce-mstaszew@toadworld.com]

Sent: Monday, February 17, 2014 10:47 AM

To: toadoracle@toadworld.com

Subject: Re: [Toad for Oracle - Discussion Forum] setting TOAD Editor window size - ARRG!

Re: setting TOAD Editor window size - ARRG!

Reply by Michael Staszewski

Ugh. My screenshot was stripped it seems. On your default Editor toolbar the desktop controls are just to the right of the Code Analysis rule set
dropdown which has the text “Top 20” in it. If you’re not seeing it and don’t want to mess around with toolbar customizations to get it back then you can break out the sledgehammer. Close Toad, delete \User Files*.lay files, start Toad. All desktops
will be back to their default layout.

Michael

On 02/17/2014 10:39 AM, Michael Staszewski wrote:

Re: setting TOAD Editor window size - ARRG!

Reply by Michael Staszewski

The selected (and only) name is “”. That’s what I use

Un-maximize your editor. is the name of the main Toad desktop. It sounds like you are using the desktop control for the main Toad window and not for the Editor. When a child form is maximized its toolbar is merged with the main Toad menu. In this
screenshot the desktop controls in red are for the main Toad toolbar. The Editor’s is in green.

On 02/17/2014 09:51 AM, gerald.novak wrote:

RE: setting TOAD Editor window size - ARRG!

Reply by gerald.novak

Brad - when I save the desktop it asks for a name. The selected (and only) name is “”. That’s what I use

Mike - followed your steps. When I open, configure and save then close and open without a connection, the data grid is still minimized.

But I think I found it (and dont understand). In TOAD options, I had auto open, save size and save position for the EDITOR. When I unchecked size and position, it works.

Doesnt make sense to me though.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


No virus found in this message.

Checked by AVG - www.avg.com

Version: 2014.0.4259 / Virus Database: 3697/7088 - Release Date: 02/12/14

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


No virus found in this message.

Checked by AVG - www.avg.com

Version: 2014.0.4259 / Virus Database: 3697/7088 - Release Date: 02/12/14

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

re:pictures not showing.

You were probably wondering why I was being so dense - I couldnt see any pictures!

Found what you were referring to and it sees to have worked.

Thanks Brad/Mike