Toad World® Forums

How do I fix the data grid to stop sizing incorrectly?

Hello all,

Two of my colleagues and I are experiencing issues with TOAD reducing our column sizes where it doesn't size to the header or the data (sizes to 1 or 2 characters of the header). It happens when we run execute/compile (F9) the first time, but when we run execute/compile again, it sizes to the data correctly as we have it set in our settings (View --> Toad Options --> Data Grid --> Visual under "Column Sizing" has the selection "Size to Data"). While this happens frequently throughout the day, we notice that it happens randomly. Sometimes it doesn't do this, but most of the time it does.

Screenshot of Output:

datagrid.jpeg

Toad for Oracle Professional (64-bit): Add-Ons: nonePart of Toad for Oracle Professional 2016 R212.10.0.30
Windows 7 Professional
64-bit Operating System

Thank you!

I also wish to know the answer to this, it is frustrating. It happens almost every time even though I’m also using the exact same settings. I think this is a bug.

Bob

Bob, try Options -> Data Grids -> Visual. I think the best setting is “Size to Header”, with both of the “Allow” options unchecked.

Excellent. Yes, I did that … but also found I had to set a "min column size: " to which I chose “90”. I consider this a work around … but it’s good enough.

Thank you,

Bob

I have those same settings where Allow options are unchecked and it’s still happening.

I’m now testing Min Column Size: 90 to see if that works today. If that doesn’t work, I’ll test with Allow columns wider than grid width and report back for people experiencing the same issue.

Thank you!

If the grids that you are looking at are on the Data tab in the Schema Browser, and “Options -> Schema Browser -> Data Tab -> Save Layouts” is checked, then the saved grid settings could be overriding auto-size settings.