Slow record fetching with Redshift ODBC driver


I have recently started using Redshift ODBC Driver with Toad Datapoint It works, but the query results return much slower than other clients.

I have tried using DBeaver via a JDBC connection and Alteryx Designer using the same ODBC connection I have with Toad.

I ran the same SELECT TOP 200 * query (with the exception of changing the date to account for DB Cache) on all three programs. The JDBC driver is the fastest running in under a second. Alteryx Designer came in second with the query returning in about 10 seconds. When I ran with Toad, the query takes a little over a minute.

Since Alteryx and Toad are using the same driver, I am wondering if there is something specific to Toad that can be addressed. I did some searching here in the forums and did not see anything regarding this issue.

Has anyone experienced this issue? Any ideas on how to improve the speed of the query results?

Thank you,


Can I ask why you're using ODBC to connect to Redshift instead of the Redshift-specific connector?
ODBC typically has limitations that can get in the way of optimal querying. Are the retrieval times faster using the specific connector vs ODBC in TDP?

That said, i would not expect to see such a discrepancy between retrieval times using different apps using the same driver. Putting Quest Dev eyes on this one.

Thanks for the quick reply. When create a new connection, here is what I see:


It seems like the only option is to use data source names defined in my ODBC connections. In my ODBC setting I have created a User DSN with the Amazon Redshift Driver named Redshift Dev. I think this might be needed as we use the Browser SAML authentication type. With all the auth settings in the ODBC DSN, I just click connect and log in through a browser.

Maybe I am misunderstanding what you mean by Redshift-specific connector? Is there another way to create a Redshift connection in Toad?

I'd like to offer assistance regarding the issue of "slow record fetching on the Redshift environment".

We noticed specific performance issues with version, which led to its removal from the official site for download. As a result, the version is no longer accessible. However, we promptly released hotfix version 6.1.2 to address these performance concerns.

After conducting quick testing on the latest GA version (Toad Data Point, I can confirm that the previously mentioned performance issues are not present:

Additionally, I took a look at the query execution speed through the mentioned competitor tool and obtained the following results:

I suggest considering an upgrade to the latest GA version (6.2), testing query performance, and sharing the results with us.

Hmmm, i had thought that TDP had a Redshift native connector... Quest Dev taking a look at this...

That did it! I have upgraded to Toad Data Point and my problem is now resolved.

Before the records would start coming in, but at a very slow pace. It was like watching text fill in on an old dial up connection. Now, the records arrive almost all at once after the query runs.

Thank you both for your response, it's much appreciated.