Toad World® Forums

sorting tables alphabetically in Object Explorer


I’ve been using the Freeware version of Toad for SQL for some time and find it great. One thing I loved, when starting with v4.6, was the ability to review all the tables in my database in alphabetical order, so that tables with the same/similar names which were created/owned by different owners were listed together. In v5.5 (and I think in V5.0) something changed and I can only list tables sorted first by the owner and THEN by the table name.

I managed to add the owner column and had hopes of being able to sort by the Table name, but it still insists on sorting by owner first, whether clicking on the Table or Owner header.

Anyone know if I’ve missed a trick? At the moment, much as a like some of the new features in v5.5, I’m migrating back to v4.6.


where sys.objects.type_desc = ‘USER_TABLE’
order by 2,1

If you want my script, which uses the above and does more, send me a private email and I will send it along. Hank Freeman


Niel, yo are correct. That functionality was changed, for reason, I do not know.

However, use this below script to GET-ER done, it came from “Larry the CableGuy”

SELECT AS schema_name ,, sys.objects.create_date, sys.objects.modify_date FROM sys.objects
INNER JOIN sys.schemas ON sys.objects.schema_id = sys.schemas.schema_id

Hi Neil,
thanks for the post. Please share with Toad dev team all your good and negative thoughts - this is the way we can see user’s feaeback and make toad better!

Regarding your particular request - we got several such requests recently and now trying to implement them in some convenient way for all users. Please note, that current sorting|grouping was made by user’s request as well.

Please see next release Beta. We expect to post it in the beginning of Aug.

waiting your feadback!

Hello, Neil!

CR 88095 has been fixed in TSS 5.6. It can sort by separate table name column. User needs to select checkbox in Tools | Options |Database| SQL Server | Show schema in separate column.

Hi Neil,

Please check out the latest beta for the changes you were talking about.
Just make sure you have turned ON “Show schema in separate column” option.