Toad World® Forums

Spectic Object Set does not work in Schema Compare

I am doing “Compare Schemas” . I created a set of specific objects to compare in the “Object Set”. I have “Specify Object Set” checked, have 3 tables in the list and they are all checked. When I do the the compare, it compares ALL objects instead of the just 3 tables that I have checked. Is there something else I need to do to have only the 3 tables compared.

Thanks

Don

That “object set” grid is just a filter, so it will only limit the object types that you enter there. So, for example, if you have tables and views checked on the options tab, but you only list a few tables in the “object set” tab, then all views and the checked tables will be compared.

So it sounds like what you need to do is go to the “Options” tab and uncheck whatever object types that you don’t want to compare.

I uncheck all objects in “Object Types to Compare” except for tables, checked the 2 tables in “object set” and Toad only compared those tables. That is exactly what I wanted to happen.

Thank You