Toad World® Forums

SQL Nav 7.1 : Formating error : Access violation at address

Hi

Today I tried to format code with CTRL+R and the program does only show an error message : Internal error occurred; see file ERROR.LOG for details.

These are the last lines from the error log file :

v7.1.0 2014-08-22 08:43:28 Access violation at address 01D14502 in module ‘sqlnavigator.exe’. Read of address 00000000

v7.1.0 2014-08-22 08:44:59 Access violation at address 01D14502 in module ‘sqlnavigator.exe’. Read of address 00000000 -> All SQL Nav sessions closed therefore

v7.1.0 2014-08-22 09:58:44 Access violation at address 01D13449 in module ‘sqlnavigator.exe’. Read of address 00000000 -> PC completely rebooted, still the same problem

v7.1.0 2014-08-22 10:08:01 Task “Format Text” in DoTerminate(): Access violation at address 00000002. Read of address 00000002

v7.1.0 2014-08-22 10:26:22 Access violation at address 01D14502 in module ‘sqlnavigator.exe’. Read of address 00000000 -> Tried to change the

v7.1.0 2014-08-22 10:26:51 Access violation at address 01D14502 in module ‘sqlnavigator.exe’. Read of address 00000000

Actually I’m no more able to format any code [:(]

Regards

Martin

Hi Martin,

Thanks for report this issue to us.

Could you have a try to backup&reset the settings for SQL Navigator 7.1?

  1. close SQL Navigator

  2. rename registry key “HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator 7.1.0” to " SQL Navigator 7.1.0bak"

  3. rename folder “%appdata%\Quest Software\SQL Navigator 7.1.0” to “SQL Navigator 7.1.0bak”

  4. now start up SQL Navigator again

  5. Please make sure “Cancel” is selected when SQL Navigator prompts the import profile settings dialog

Starting with fresh settings helps to avoid errors from old settings. If this doesn’t stop the error, please send us support bundle files.

Meanwhile, we will keep eyes on such errors and we are doing more works to avoid such error in v7.2.

Thanks,

Michael

Hi Michael

Tried this solution, but the result is still the same. The only difference I see, is that all parametrisation of the program has gone (like a reset)

CTRL+R on SELECT 1 FROM DUAL does nothing and trying to change the default formating settings gives : v7.1.0 2014-08-22 11:25:20 Access violation at address 01D14502 in module ‘sqlnavigator.exe’. Read of address 00000000

Regards

Martin

Hi Martin,

Could you please attach support bundle files for us?

we still investigating your issue.

Michael

Hi Michael

Sure, if you tell me wich/where these files are :wink:

Regards

Martin

Hi Martin,

Sorry, my mistake.

please go to Help menu and click on Create support bundle files, then attach .dta and .prof file for us

Regards,

Michael

Hi Michael

Hope you can download them from here : https://drive.google.com/a/zieglergroup.eu/folderview?id=0ByneMJGGmZ6GZ3FjN1EwbnNlcTg&usp=sharing

PS : meanwhile I reinstalled the program, but nothing has changed to the problem.

Regards

Martin

Hi Martin,

sorry that It is failed to download your support bundle files from your link.

May i ask you if can send your support bundle files to me by Email.

My Email: Michael.Luo@quest.com

Thanks,

Michael

Hi Michale

Here are the asked bundel files. Many thanks for your help.

Regards

Martin

Bien à Vous/Best regards/Beste groeten

Martin Goblet

Analyste programmeur


: +32(0)87 592 463

: +32(0)87 592 201
martin_goblet@zieglergroup.com

www.zieglergroup.com

2014-08-25 4:37 GMT+02:00 michael bounce-michael@toadworld.com:

RE: SQL Nav 7.1 : Formating error : Access violation at address

Reply by michael
Hi Martin,

sorry that It is failed to download your support bundle files from your link.

May i ask you if can send your support bundle files to me by Email.

My Email: Michael.Luo@quest.com

Thanks,

Michael

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from SQL Navigator - General notifications altogether.

SQL Navigator - Discussion Forum

Flag this post as spam/abuse.

Hi

Found finally a solution, but I miss all the ADVICES from the formating.

Solution :

  • uninstalled SQL Nav, deleted entries with regedit, deleted Quest software directories (old versions)

  • reinstalled V 7.1

  • as soon as I wanted to change the formatings settings ->error

  • changed the default formating file from c:\users… \FmtOptions.opt to c:\Program Files\Quest Software\SQL Navigator for Oracle 7.1\FmtOptions.opt.xml (my backup file) -> crash

  • changed the default formating file from c:\users… \FmtOptions.opt to c:\Program Files\Quest Software\SQL Navigator for Oracle 7.1\FmtOptions.xml (empty file) -> first time I was able to change a settings with no error message

  • modified manually all my settings.

It works now, but I do no more find all the Advices. Have they gone ?

Regards

Martin

Hi martin,

Thanks for your solution.

i can produce your format issue when change format options using your bundle files.

it seem that have problem with old version formatter, we have create story SQLNAV-1735 for you, we will try to fix it as soon as possible.

For the Advices, yes, they gone when using new version of formatter.

Thanks,

Michael

Hi Michael

Will we get the advices back, or is it definitive. I found them very useful.

Is there a place where we can see all the stories SQLNAV… and their status ?

Regards

Martin

Hi Martin,

Thanks for your suggestion, we already have story SQLNAV-1736 for getting the advices back, we will try to bring back later.

And all the stories of SQLNAV will be record in our system, if one of story fixed or done, we will update to post of community at once.

Thanks,

Michael

Hi Michael

I have been very happy for a very little while [:’(]. The formatting doesn’t work anymore. It tells again that the code has been formatted, but does nothing.

Hope you’ll find soon a solution to this problem, because this formatting helps a lot.

Regards

Martin

Hi Marin,

Does all scripts can not be format ? or just specify one?

And Could you sent your new bundle files (your current bundle files) to me again ?

we will try to find a solution for you.

Regards,

Michael

Hi Michael

Mail with bundel files have been sent to your address. No code can be formated, even the simplest :wink:

Regards

Martin

Hi Martin,

i didn’t get your attachment files by email, Could you send me again?

My Email: Michael.Luo@quest.com

Thanks,

Michael

Hi Mickael

Any progress concerning this problem ?

Regards

Martin

Hi Martin,

We are sill working on progress for you. we will let you know when we fixed it

And we will try to fix in v7.2 beta

Thanks,

Michael

Hi Martin, We are about 1 month out from the 7.2 beta, please check back and give it a try. -Brad