Toad World® Forums

SQLNav crushes


#1

Hi,

I am on v.6.2.0.1500
Every time I try to connect to the database, the SQLNav closes itself, without any error. It just disappears from my screen. No logs in the Event Log.

I am on Win7 Prof and I use “Run as administrator” setting. I have two ORACLE_HOMEs on this laptop and I picked my 10.2.0.3 client home as a default home. It is also reflected in my system variables.

Please, let me know how to fix it this.

Thanks,
M


#2

Hi,

Please provide more information:

  1.   You said that you are using Oracle 10.2.0.3 client, what version is the other Oracle client? Are you using instant clients? 
    
  2.   Can you try to use the other Oracle client as your default home?
    
  3.   Are you using 32 bits or 64 bits Win7?
    
  4.   Have you try to connect different database?
    
  5.   Would you like to try our [current beta](http://sqlnavigator.inside.quest.com/thread.jspa?messageID=107739) release and install side by side? 
    

Regards,
Jeff


#3

Hi,

Following up with Jeff’s note:

  • SQL Navigator supports 64-bit for Windows XP/Win7 with a 32-bit Oracle Client.
  • If you have Win7 64 bits OS, Bydefault SQL Navigator isinstalled in ‘c:\Quest software\SQL Navigator6.x.x’. SQL Navigator cannot detect location of OCI.dll if there is‘()’ in the installation path. I would suggest that you reinstall SQL Nav into a directory outside ‘program files’, ie. install SQL Navigator into c:\Quest Software…
  • Please also make sure that you have tnsnames.ora file in your Oracle home.

Regards,
Bruce


#4

Hi, jchan,

  1. Both clients are not instant, meaning those are full administrator installations. The other client is 11.2.0.1.

  2. When I pick 11g client as a default PORACLE_HOME, it throws the following:

"Access violation at address 77BCADE9 in module ‘ntdll.dll’. Write of address 04194A55 error: "

  1. Win 7 32 bit

  2. It works for some of my databases, but not the one that i really need to use it for.

  3. I would not, thank you. Our policy do not allow to install beta versions.


#5

Hi Bruce,

I do have tnsnames in my $ORACLE_HOME/network/admin - the drop down list can see all my databases there. Also, I think I would be able to reinstall the programm, but the fact that it works with some databases and doesn’t work with others makes me to think that this is not an installation issue.

I can connect to the database with the same credentials via SQL+, but when I use SQLNav - it just closes by itself.

Thanks,
M


#6

Hi,

The symptoms point to something specific in the database(s) that SqlNav cannot “access”. Maybe those have a specific version? Are 32- or 64-bit? Locally installed or on a remote server?
There also may be something specific in the tnsnames.ora file that makes SqlNav abort (like connect through SID or SERVICE_NAME, with or without “SERVER = DEDICATED”,…).
Just my 2 (Euro)cents…


#7

Radar,

Do you know what specific could cause this behavior? tnsnames contains SERVICE_NAME and SERVER=DEDICATED, and there are other databases that have the same parameters and I am able to connect to.

I also tried to connect to the same database from another box - and it works fine.

please, provide the resolution.
thanks,
M

ps: the problem DB is remote 64bit one

Message was edited by: mgurenich_265


#8

Hi,

I cannot replicate exactly same problem but I have an environment that when click OK button in SQLPlus on Log On widow, SQLPlus just disappear. When I “Run as administrator” and this problem fix.

Try right click sqlnavigator.exe/shortcut and select “Run as administrator”.

Alternatively, you may change your UAC settings to “Never notify”(require restart).

Message was edited by: jchan


#9

Hi,

I don’t have a clue as to what could cause the problem - but the fact that only a few databases are affected would seem to point to a problem with those databases (or the way they are connected with).
The new fact - that the “problem” database can be connected to from another PC - points to another possible cause, assuming both boxes use the SAME tnsnames.ora file: a problem with the Oracle client installation. JCHAN’s suggestion might help here.


#10

Radar,

those are two different boxes, two different clients and two different tnsnames.ora files. I can connect from Win 2003 to the given database, but cannot from Win 7… This is kinda annoying.

Does SQLNav have any logs? Event viewer has no info regarding the issue.

Thanks,
M

PS: as noted above, I am running SQLNav as an admin.


#11

Hi,

Have you tried to copy the “good” tnsnames.ora file from the Win2k3 machine to the Win7 one? (take a backup of the original on the Win7 machine!)
And while you’re doing that, please do the same for the sqlnet.ora file (in the same folder). Just to rule those out as a possible cause…


#12

Hi,

Just let you know that we are still trying on this issues for you.

On my Win7 with 2 oracle home: Full client10g and 11g (light client): I also manage to get the ntdll.dll error when select home, but issue in my test environment is different:

  • Having 10g client as default, ie. first in path, I can use 10g to connect any DB. However, if I select 11g home from the drop down list, then if I select 10g client, I will get the ntdll.dll as you reported. After getting this error, 10g client cannot be selected anymore, ONLY 11g client can be used to connect to any DB.

We expect the crashing issue you reported occurs in the third party component to handle the DB connection, there is currently no log file for such issue.

Could you please try this for us next, we would like to eleminate if the loading of the code editor causing the app crashed:

  • Start up SQL Navigator.
  • Go to View->Preference. Please make sure the option Show Code Editor as attached screen shot is OFF.
  • Connect to the DB and see if you could get any further.

Please let us know how you go…We might need to consider sending you a new binary with some debugging log to help us identify the underlined issues.

Thanks and regards,
Bruce

Message was edited by: bruceduong
preference.jpeg


#13

Hi,

If you still have the same problem after setting the Show Code Editor preference OFF,
could you please try the following:

Rename the following registry key HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator x.x.x where x.x.x is the SQL Navigator version you are using, then re-launch SQL Navigator.

Thanks,
Bruce


#14

hi, bruceduong.

Thank you for keep getting this resolved. Unfortunately, I am still having issues… :frowning: So, I set Show Code Editor preference to OFF, got the very same thing. Then I went to HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator 6.2.0 nd renamed it to SQL Navigator 6.2.0_bak - restarted SQLNav and got the following:

Unhandled Exception at startup - Failed to set data for ‘’
Report the problem to Quest Support. Application will be terminated (some memory loss is possible) when you press OK.

I clicked OK, got this:

“Access violation at address 041F159A in module ‘sqlnavigator.exe’. Read of address 000002CC.
No action required. Report the problem to Quest Support. Application will be terminated (some memory loss is possible) when you press OK.”

and the window disappeared again…

That’s where am i…


#15

I compared the tns entries for the problematic databases - they are the same on both, win7 box and win2k3. sqlnet.ora is the default ones on both machines.

there is only one difference, i am inclining to think that this is the root of the problem: SQLNavigator on win2k3 machine is at release 6.2.1.1521 and the one on my win7 laptop is at release 6.2.0.1500

Shall I upgrade my laptop’s SQLNav to the same version as win2003?

Please, advise.

thanks,
M


#16

i hate to report, that I’ve upgraded my laptop’s SQLNav up to v.6.2.1.1521 and I am still having the very same issue.

please, let me know what else can be done in order to fiz that.

thanks,
M

PS: I am still able to connect to other databases as I was on prev release…
PPS: So it crushes only when the login credentials are correct. If I type the wrong password connecting to the problematic database, it’ll throw an error invalid username/password… freaking annoying issue… >:


#17

Hi,

As you mention that “the problem DB is remote 64bit one” can you provoide more information about that DB? We may try to install the same DB in our environment.

Thanks
Jeff


#18

Hi M,
Thank you for your update.

Sorry to hear that you have the issues.

I will keep you posted…

Thanks,
Bruce


#19

dear mgurenich_265

here is the solution right click on sqlnavg >choose troubleshooting comparability >
then choose > try recommended setting >then start the program > the sqlnavg will run successfully this time > close sqlnavg and back to the previous window click >next>then save setting.

I hope this will help you .

regards;
yahia
s2.jpeg


#20

dear mgurenich_265

here is the solution right click on sqlnavg >choose troubleshooting comparability >
then choose > try recommended setting >then start the program > the sqlnavg will run successfully this time > close sqlnavg and back to the previous window click >next>then save setting.

I hope this will help you .

regards;
yahia
s1.jpeg