Toad World® Forums

SQL Server Database Error in Object Explorer

Hi,

After several days of working across SQL Server and Oracle connections with no issues, today I started encountering the following error whenever I connect to a SQL Server database:

“An expression of non-boolean type specified in a context where a condition is expected, near ‘AND’.”

It seems that the connection itself is successfully made, as I am able to run queries, but I am not able to see any information in the Object Explorer (instead I get a red X icon with “SQL Server Database Error” next to it). If I use SQL Server Mgmt Studio, I am able to connect, browse objects and run queries with no issues. Also, I am still able to connect to Oracle in Toad and use the Object Explorer with no issues.

I did not modify any connection settings between my last successful SQL Server connection and the start of the error. I have also tried connecting to several different SQL Server servers / instances and see the same error each time. One change I did make today (prior to the start of the error) was to create / apply an Object Explorer filter while working in one of my Oracle connections. I’ve noticed since then that it seems to default to the “IN” search condition vs. "Glob (* wildcard), and suspect perhaps something in that area may be at the root of my issue.

For reference, I am using Toad for Data Analysts v2.7.

Has anyone else encountered (and resolved) an error like this? Please advise, thanks!!

I have seen this error and have experienced it myself. I will check with SQL Server team to see what the issue is.

I do know that this issue does not occur in TDA 3.0.1. Can you upgrade to latest version?

Debbie

I checked with some of the developers and it seems this error is coming from a filter in the Object Explorer (even if you are not using one right now).

Try renaming your data directory. To do this go to Help | About and access the Application Data Dir. Close TDA down and then rename that directory. Restart TDA. You can then copy in your settings.xml and connections.xml to get back your connections and configurations.

Debbie

Thanks Debbie!! That did the trick and I am no longer seeing the SQL Server Database Error. Your speedy research/ response is much appreciated!