Toad World® Forums

Losing connection in Object Explorer after running script

Hi,

I just recently encountered an error after 6 months of using the latest release of 2.7 where I lose connectivity to the database in the object explorer after I run a query or execute a job.

Has anyone else experienced this issue? I re-installed TDA just to be safe, but the problem is still happening.

What type of database are you connected to? If Oracle make sure you use an OCI connection instead of direct connect as these are easily lost.

If not Oracle it is possible idle connections are being closed by your server. However in this case TDA should reconnect. What are you seeing in the application?

Sent from my iPhone

I am using both Oracle and SQL Server connections.

The thing that throws me off is that this never happened before?

Basically if I run a script, the Obiects explorer window becomes a blank white page instead of showing the tables etc…and I have to re-connect to the database. IT has made some changes recently…so I’m wondering if a setting has thrown this off?

That’s odd. We have code underneath the hood that checks to see if the connection is closed and if it is, we just silently reconnect. Your situation seems different.

What is in the scripts? Inserts? Creating temp tables? Or just select statements?

I would check with your DBA to see if there has been any changes to the database. Maybe you have been assigned a new resource profile limiting the number of connections you can have. If this is the case, we may be trying to opena connection and it is being refused. Then when you reconnect it cleans up the extra connections.

Debbie

I think it’s something on my side because it’s only happening with certain connections.