Substitution Variable Prompting setting is ignored for all options of execution query (F5/F9/Ctrl+F5 ...)

Hi Experts,

I have a problem with Substitution Variable Prompting in TOAD version 17.0.353.2906 Patch1.
I tried to use new notation for building JSON_OBJECT like:

  with rec as (select 100 as val
                 from dual)
select json_object (
         'contractReference' : rc.val
       ) as fff
  from rec rc;

where is used colon instead of "value" keyword. I tried this in SQL Delevoper and SQL Plus and It works as expected. One row with correct JSON is shown.

If I execute this query in TOAD using F5, Ctrl+F5, F9 ... The "Substitution variable prompt" popup is shown. Everytime. Setting of this attribute is completely unusable (even through Toad Options .. and right click in Editor where you can set It too). Could You please try It in some other versions of TOAD ? (or It is bug just in v. 17 and above).

Toad Options:



This problem will occur in all versions of Toad. We'll have it fixed as soon as we can.

Thanks for reporting it.