Toad World® Forums

Tables | Import new line (\n) data from xlsx

I imported an xlsx file to an empty table. The imported values of a column in the table are starts with "x000D" value, but in the original xlsx file these are new lines.

From the following forum:


"...
This behaviour is mentioned a few places on the internet as well such as here or here or here.*
..."

I tried to reproduce this by:

  1. Running this query and exporting it to an XLSX file:
    select EMPNO, CHR(13) || CHR(10) || ENAME as ename, JOB, MGR, HIREDATE, SAL, COMM, DEPTNO
    from emp

  2. Importing that file back into the table

...but after that the table looked as I expected, with an actual line feed. I also tried with just CHR(13) instead of CHR(13) || CHR(10).

How can I create a file to reproduce the problem?

I send you offline a sample xlsx and the structure of the table.

Tamas and I have been communicating by email, but incase anyone else sees this:

It is broken in Toad 13.3 (and possibly earlier versions), but it is fixed starting in Toad 14.0.