Toad World® Forums

Team Coding Sub-Projects folder location

Hi all,
When I click the "Create Folder" button to create the Schema object folders (TABLE, VIEWS, PROCEDURE, SEQUENCE ...) it is going into the Root folder of my C: drive instead of the TFS working project folder.
The parent folder name is being created in the correct location but nothing else.
I am using version 12.6.0.53 Toad for Oracle Xpert and Team Foundation Server 2013.

How do I get the TABLE, PROCEDRE, PACKAGE folders to go into the Working folder instead of the Root of drive?
Thanks!

team_foundation_server.jpeg

Hello .

It sounds like a TFS workspace issue. Can you send a screen shot with of the Team Foundation Server login from Toad? The menu item is Utilities – Team Coding
– VCS Loigon … This will show how Toad is reading your workspace information.

Thanks

Stephen

From: greg.varela [mailto:bounce-gregvarela@toadworld.com]

Sent: Monday, October 06, 2014 12:33 PM

To: toadoraclebeta@toadworld.com

Subject: [Toad for Oracle - Beta Discussion Forum] Team Coding Sub-Projects folder location

Team Coding Sub-Projects folder location

Thread created by greg.varela

Hi all,

When I click the “Create Folder” button to create the Schema object folders (TABLE, VIEWS, PROCEDURE, SEQUENCE …) it is going into the Root folder of my C: drive instead of the TFS working project folder.

The parent folder name is being created in the correct location but nothing else.

I am using version 12.6.0.53 Toad for Oracle Xpert and Team Foundation Server 2013.

How do I get the TABLE, PROCEDRE, PACKAGE folders to go into the Working folder instead of the Root of drive?

Thanks!

[

](http://www.toadworld.com/cfs-file.ashx/__key/communityserver-discussions-components-files/86/team_5F00_foundation_5F00_server.jpg)

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

It appears that it is pointed at the right place.
I will try to create a new TFS Workspace using a different Working Local folder location to see what happens.

TOAD_TFS_info.jpeg

Thanks, I will try to see if I can replicate your setup.

From: greg.varela [mailto:bounce-gregvarela@toadworld.com]

Sent: Monday, October 06, 2014 3:27 PM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Team Coding Sub-Projects folder location

RE: Team Coding Sub-Projects folder location

Reply by greg.varela

It appears that it is pointed at the right place.

I will try to create a new TFS Workspace using a different Working Local folder location to see what happens.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Hello Stephen,

Long time no see :wink:

I last worked with Team Coding 6 in Toad 10.X and just started to analyze all the new stuff related to versioning with TFS that you have built-in since than.

I downloaded the latest version 12.6.0.53 and I am using Team Foundation Server 2013 RTM.

Is this Update 3 supported? What about Update 4? When not, which is the last supported TFS 12013 update?

Unfortunately, I did not manage to setup Team Coding with TFS intuitively at the first try ;(

I am getting the same errors as greg above - the folders are created in the root C: folder instead of the folder where the VSC project is mapped in the TFS workspace.

I get a lot of errors in the output window:

Is there any official step-by step guide how for setting team coding in Toad 12.6.0.53?

The Team Coding dialogs have changes since this link (www.toadworld.com/.../10857.team-coding-purpose-and-setup.asp) and this link (www.toadworld.com/.../9359.version-control-and-team-coding-in-toad-for-oracle-11-6.aspx).

Thanks in advance,

Cheers, Ana

Hello

We have not tested with Update 4. I need to update my dev environment to take a look at the the versions. What version of Visual Studio / Team Explorer is
installed on your client.

Can you also please send screen shots of your TFS settings in Toad.?

Thank you

From: Ana Roje Ivancic [mailto:bounce-AnaRojeIvancic@toadworld.com]

Sent: Wednesday, December 17, 2014 9:53 AM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Team Coding Sub-Projects folder location

RE: Team Coding Sub-Projects folder location

Reply by Ana Roje Ivancic

Hello Stephen,

Long time no see :wink:

I last worked with Team Coding 6 in Toad 10.X and just started to analyze all the new stuff related to versioning with TFS that you have built-in since than.

I downloaded the latest version
12.6.0.53 and I am using
Team Foundation Server 2013 Update 3.

Is this Update 3 supported? What about Update 4? When not, which is the last supported TFS 12013 update?

Unfortunately, I did not manage to setup Team Coding with TFS intuitively at the first try ;(

I am getting the same errors as greg above - the folders are created in the root C: folder instead of the folder where the VSC project is mapped in the TFS workspace.

I get a lot of errors in the output window:

Is there any official step-by step guide how for setting team coding in Toad 12.6.0.53?

The Team Coding dialogs have changes since this link (www.toadworld.com/…/10857.team-coding-purpose-and-setup.asp )
and this link (www.toadworld.com/…/9359.version-control-and-team-coding-in-toad-for-oracle-11-6.aspx).

Thanks in advance,

Cheers, Ana

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Hello and thank you for your quick answer.

I am testing using VIsual Studio 2013 RTM and Team Foundation Server 2013 (I corrected this in the initial post).

Attached you can find my TFS setting in Toad (I added General and Check in Tab, the other two have default values)

Here is part of the "VCPDebug.log" when trying to create subprojects (subfolders):

==================================================================

Time Stamp: 12/16/2014 2:25:03 PM
Method Name: QueryItemsExtended
Request: <?xml version="1.0"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://www.w3.org/2003/05/soap-envelope" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">SOAP-ENV:BodyNonDeletedFolder0</SOAP-ENV:Body></SOAP-ENV:Envelope>

Response:

<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">soap:Body</soap:Body></soap:Envelope>

==================================================================
Time Stamp: 12/16/2014 2:25:03 PM
Method Name: PendChanges
Request: <?xml version="1.0"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://www.w3.org/2003/05/soap-envelope" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">SOAP-ENV:BodyTOADVSALM\Brian00</SOAP-ENV:Body></SOAP-ENV:Envelope>

Response:

<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">soap:Bodysoap:Faultsoap:Codesoap:Valuesoap:Sender</soap:Value>soap:Subcodesoap:ValueInvalidPathException</soap:Value></soap:Subcode></soap:Code>soap:Reason<soap:Text xml:lang="en">TF10121: The path 'TYPE_BODY' is not found or not supported. Type or select a different path.</soap:Text></soap:Reason></soap:Fault></soap:Body></soap:Envelope>

==================================================================
Time Stamp: 12/16/2014 2:25:03 PM
Method Name: QueryItemsExtended
Request: <?xml version="1.0"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://www.w3.org/2003/05/soap-envelope" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">SOAP-ENV:BodyNonDeletedFolder0</SOAP-ENV:Body></SOAP-ENV:Envelope>

Response:

<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">soap:Body</soap:Body></soap:Envelope>

==================================================================
Time Stamp: 12/16/2014 2:25:03 PM
Method Name: QueryItemsExtended
Request: <?xml version="1.0"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://www.w3.org/2003/05/soap-envelope" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">SOAP-ENV:BodyNonDeletedFolder0</SOAP-ENV:Body></SOAP-ENV:Envelope>

Response:

<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">soap:Body</soap:Body></soap:Envelope>

Thank you,

Ana

Hello Stephen,

Until you resolve this problem I found a workaround for TFS mappings:

  • you need to set the workspace mapping from the TFS root folder “$/” to “C:” or the root from some other disk.
    Additionally, the TFS root needs to to be mapped here, not some subfolder in TFS, because otherwise it still does not work.

Further info on my blog under Workaround for Setting up Workspace Mappings in Toad for Oracle 12.6 and Team Foundation Server 2013 (RTM or Update N).

Cheers,

Ana