Toad World® Forums

Team Coding - The object has been modified dialog


#1

The Team Coding dialog that pops up when I am about to close an editor tab that contains a PL/SQL object in it makes me crazy. Here are a few of the things that I don’t like:

  1. If I have made changes but decide I don’t want to compile them, I tell the dialog to not compile. After a minute or two, the dialog pops up again. It always makes me nervous.

  2. Sometimes it pops up even if I have not made any modifications.

  3. There are times it ends up stuck behind another window. But there is no way to Alt+Space move the window and no shortcut so I can just press Alt+N to get it to close. Esc won’t work and Enter won’t work. I’ve had to just kill Toad because of it which isn’t a good option.

On the positive side of things, even though I’m the primary person making any changes in the DB, I can’t imagine NOT using Team Coding. I really appreciate all the work that has gone into it, integrating it so well to GIT. I don’t often have to look back at previous versions of code, but the times I do, it is a life-saver!

Blessings,

Phyllis


#2

Hi Phyllis,

Have you tried unchecking the option “Check-in object on closing” on the User Settings page of your Team Coding configuration window? That should remove the prompt to check in the object if it’s been modified but not compiled. I do see that it can sometimes prompt twice. I’ll take a look into that to see what’s causing it.

As for the issue where the prompt can get stuck behind other windows, we’ve had that problem with other windows in Toad as well. Unfortunately, there’s no good solution for it. It’s a standard Windows message box, so it’s something that’s caused by Windows’ z-order placement.

Thanks! I’m glad you’re liking Team Coding as an overall feature! If you have any other suggestions or additions for it, please do feel free to let me know.

-John


#3

Oh, I thought that had to do with the prompt I get when I close Toad and it shows me all the objects I have checked out. Thank you!

It’s interesting that some of the dialog boxes have the Window menu that can be used to move them, and others don’t. At least me setting the other option will take care of the problem with this dialog. :slight_smile:

Thank you!