Toad World® Forums

The table *** can not be mapped (Cross-Connection)

Hello,

Im running a cross connection query between multiple servers and I wasnt having a problem until I added a few more servers to my query. Now I keep getting an error message stating the new table cannot be mapped, If I delete the new stuff, the query runs fine. Its having an issue mapping the tables on the servers I just added I guess. These are DB2 databases if that helps.

As a trial I created an new cross-connection query builder and tried just adding one of the newer DB2 databases to this only, and I still get the error. If I run a single query against the db it runs no problem. Is there a way to fix this or go around this type of error. I need to run a query across 17 connections which is insane, but only get a handful to work.

this should not be happening. Do you mind opening a support case so we can specifics on the issue? there is a product support link under the help menu

Thank you Debbie,

I went ahead and submitted a support request.

What is the SR number? I will see if i can escalate it.

Looks like Chad Ossiginac is communicating with me.

Service Request # 4099527

If you don't mind my asking, what was the resolution? I am having the same issue.

Hi, I'm quoting the original support case resolution:
"Here is the link to an official document about the error, that includes the related information on how to “Grant privilege to user”.

http://www-01.ibm.com/support/docview.wss?uid=swg21381783

Please take a look at this document, grant the privilege to the user, and let me know if that resolves the issue."