Toad World® Forums

Toad 11 bugs - attn. TOAD dev. team

Hello,

I installed TOAD 11 on a Windows XP computer. I noticed the following bug:

  1. I uploaded approx. 1,200,000 records into Customers table from an Access database through an ODBC connection (in several batches).
  2. I checked RECORD COUNT on Customers, it correctly shows 1,200,000 records (right-click on Customers table, chose Record Count from menu).
  3. However, when I click on TABLES node in TOAD in order to show tables summary, TOAD reports only approx. 600,000 in Num Rows column for this table.

I closed the connection and reopened it. Num Rows still incorrect
I closed the whole application and reopened it - finally Num Rows column shows a correct count.

Can you please investigate this bug?

Also, another issue I noticed is that I cannot highlight a word in a comments block when I double click on it, in editor. Instead of highlighting the word I chose, a completely different word is highlighted… Please check

Regards,
M.R.

This is not a bug. The Num Rows data that Toad shows is from the info in
user/all/dba_tables, which we get from Oracle.

To update it, you need to tell Oracle to analyze your table again.

Thanks for the clarification JDORLON.
Can you also comment on the second reported issue? This one seems an obvious bug to me.

Regards,
M.R.

Issue #2 is unfortunately a known issue that has existed for a while. Try
Courier New font if you are using Courier (or Courier if you are using Courier
New). I can’t recall which of the two has the issues, but the other one resolves
it.

Michael

I’ve found that making the comments non-italics fixes the problem.

Mike

On Thu, Sep 29, 2011 at 12:14 PM, Michael Staszewski <
michael.staszewski@quest.com > wrote:

Issue #2 is unfortunately a known issue that has existed for a while. Try
Courier New font if you are using Courier (or Courier if you are using
Courier New). I can't recall which of the two has the issues, but the
other one resolves it.

 

Michael

Sorry, I usually don’t notice those “oh, and this doesn’t work
either” at the end of emails. I think the first issue sucks up the
entirety of my attention span.

Anyway - Courier New is the one that works right. Just remember newer is better.
:slight_smile:

Thank you Michael, I shall give it a try.

Regards,
M.R.

Great, it’s fixed now!

Regards,
M.R.