Toad World® Forums

Toad 12 - File Open dialog - no longer able to filter subset using wildcard *

In prior versions of Toad for Oracle it was possible to select Open File button from toolbar (or File > Open File from menu) , enter a partial file name with " * " wildcard(s), i.e. " partial_filename_text_to_be_searched.sql ", press enter and the initial view of files was filtered to only those file names matching the criteria, from which the specific file(s) could be selected and subsequently opened.

Is there any potential for similar behavior to be returned to the latest version of Toad ?

Thanks in advance.

Hi Michael,

This works for me if the .sql is not added at the end. Please give this a try.

Thanks,

Brad

From: MichaelA [mailto:bounce-MichaelA@toadworld.com]

Sent: Monday, June 24, 2013 3:12 PM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] Toad 12 - File Open dialog - no longer able to filter subset using wildcard *

Toad 12 - File Open dialog - no longer able to filter subset
using wildcard *

Thread created by MichaelA

In prior versions of
Toad for Oracle it was possible to select Open File button from toolbar (or
File > Open File from menu) , enter a partial file name with " * " wildcard(s), i.e. " *partial_filename_text_to_be_searched *.sql ", press enter and the initial view of files was filtered to only those file names matching the criteria,
from which the specific file(s) could be selected and subsequently opened.

Is there any potential for similar behavior to be returned to the latest version of Toad ?

Thanks in advance.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Hello again Michael,

I just did a comparison between Toad 11.6 and 12. I see what you’re talking about. It appears there was a change of behavior here. In 11.6, when you pressed
“enter” after entering a filter, the file view would change. In 12, you can still filter, but the dropdown list from the file name dialog is filtered, not the files in the main window.

The developer will have to chime in as to whether the old functionality can be added back or not.

Thanks,

Brad

From: MichaelA [mailto:bounce-MichaelA@toadworld.com]

Sent: Monday, June 24, 2013 3:12 PM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] Toad 12 - File Open dialog - no longer able to filter subset using wildcard *

Toad 12 - File Open dialog - no longer able to filter subset
using wildcard *

Thread created by MichaelA

In prior versions of
Toad for Oracle it was possible to select Open File button from toolbar (or
File > Open File from menu) , enter a partial file name with " * " wildcard(s), i.e. " *partial_filename_text_to_be_searched *.sql ", press enter and the initial view of files was filtered to only those file names matching the criteria,
from which the specific file(s) could be selected and subsequently opened.

Is there any potential for similar behavior to be returned to the latest version of Toad ?

Thanks in advance.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Hi Michael,

Hmm… This issue was addressed at one point during the beta cycle; however, it looks like it found a way to sneak back in. I don’t see any reason why we wouldn’t be able to get that fixed for the patch. We’ll get it taken care of.

Thanks for letting us know about this!

-John

Hi again Michael,

I think I know where the problem is. Quick question, Michael: Does the substring you’re searching exist anywhere in the path? For example, if you are searching for “test”, would you by any chance be looking in “c:<folder>\test<folder2><files>”?

Thanks,

-John

One other thing to note: pressing the [Enter] key appears to close the filtered drop-down box; however, it doesn’t automatically register the default [Open] action, which would execute the filter. Pressing the [Enter] key again, however, will execute the filter.

So, if the above situation is not the case for you, try pressing the [Enter] key again and see if the filter is applied.

Let me know what you find.

Thanks!

-John

Doesn’t work for me. In my working folder, that includes files named x.sql, x-compare.sql, and other files whose names start with x, in the file/open dialog
box, I type

x*

(and get the drop-down showing all the x files) and hit Enter once, and the central window still displays all the files in the folder; and I hit Enter again,
and ALL the files disappear from that window, whether they start with X or not. All that’s still visible are the subfolders.

Nate Schroeder

US Row Crops IT Data Management Team

Monsanto Company

800 N. Lindbergh Blvd. G3WB - Saint Louis, MO - 63167

314-694-2592

From: John Bowman [mailto:bounce-jbowman@toadworld.com]

Sent: Tuesday, June 25, 2013 9:20 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Toad 12 - File Open dialog - no longer able to filter subset using wildcard *

RE: Toad 12 - File Open dialog - no longer able
to filter subset using wildcard *

Reply by John Bowman

One other thing to note: pressing the [Enter] key appears to close the filtered drop-down box; however, it doesn’t automatically register the default [Open] action, which would execute the filter.
Pressing the [Enter] key again, however, will execute the filter.

So, if the above situation is not the case for you, try pressing the [Enter] key again and see if the filter is applied.

Let me know what you find.

Thanks!

-John

This e-mail message may contain privileged and/or confidential information, and is intended to be received only by persons entitled

to receive such information. If you have received this e-mail in error, please notify the sender immediately. Please delete it and

all attachments from any servers, hard drives or any other media. Other use of this e-mail by you is strictly prohibited.

All e-mails and attachments sent and received are subject to monitoring, reading and archival by Monsanto, including its

subsidiaries. The recipient of this e-mail is solely responsible for checking for the presence of “Viruses” or other “Malware”.

Monsanto, along with its subsidiaries, accepts no liability for any damage caused by any such code transmitted by or accompanying

this e-mail or any attachment.

The information contained in this email may be subject to the export control laws and regulations of the United States, potentially

including but not limited to the Export Administration Regulations (EAR) and sanctions regulations issued by the U.S. Department of

Treasury, Office of Foreign Asset Controls (OFAC). As a recipient of this information you are obligated to comply with all

applicable U.S. export laws and regulations.

Thanks to both Brad and John for clarifying the current standard behavior for filtering file names with wildcard character in the v12 Open File dialog.

After following your directions, I now notice the filtered filename list dropdown available after the 1st click of the Open button (was so focused previously on an expected refresh of the File View pane, that I hadn’t noticed the dropdown), and now I’m also able to see the refreshed File View pane after the 2nd click of the Open button.

My personal preference would have been to reverse the current actions (1st click refreshes File View, 2nd click presents dropdown), as I personally find the dropdown less useful than the refreshed File View pane. I will therefore most likely get in the habit of clicking the Open button twice to try and achieve a behavior most closely approximating that of the prior versions.

My 2¢

Thanks again to both Brad and John for your helpful guidance.

Hmmm. Seems to work if what I type starts with a star.

x*

shows me no files;

x

shows me the files that start with x, as well as anything with x in the name (including all *.txt files!)

x.sql

shows me SQL files that start with x or have x in the name.

So I can filter by anything except how a filename starts, I guess.

Nate Schroeder

US Row Crops IT Data Management Team

Monsanto Company

800 N. Lindbergh Blvd. G3WB - Saint Louis, MO - 63167

314-694-2592

This e-mail message may contain privileged and/or confidential information, and is intended to be received only by persons entitled

to receive such information. If you have received this e-mail in error, please notify the sender immediately. Please delete it and

all attachments from any servers, hard drives or any other media. Other use of this e-mail by you is strictly prohibited.

All e-mails and attachments sent and received are subject to monitoring, reading and archival by Monsanto, including its

subsidiaries. The recipient of this e-mail is solely responsible for checking for the presence of “Viruses” or other “Malware”.

Monsanto, along with its subsidiaries, accepts no liability for any damage caused by any such code transmitted by or accompanying

this e-mail or any attachment.

The information contained in this email may be subject to the export control laws and regulations of the United States, potentially

including but not limited to the Export Administration Regulations (EAR) and sanctions regulations issued by the U.S. Department of

Treasury, Office of Foreign Asset Controls (OFAC). As a recipient of this information you are obligated to comply with all

applicable U.S. export laws and regulations.

Hi Nathan,

Yes, I’m seeing what you’re seeing as well. This is caused by the same problem mentioned in my other response. We’re using a built-in Windows API function
to do the comparison; however, the filters entered are actually being compared to the full path of each file, rather than just the file name itself. Unfortunately, in some cases this will result in extra files being included if the path contains the filter
criteria. In your case, since the full path doesn’t begin with the letter “x”, none of the files are included.

This is an easy fix going forward – it just slipped past us in the beta process. Until it’s fixed, you may need to use the filter “x” or “x.”. I
know that may not be the best solution if you have an “x” in the path; but if you don’t, it’ll filter what you need.

Thanks again for pointing this out!

-John

From: nathan.e.schroeder [mailto:bounce-nathaneschroeder@toadworld.com]

Sent: Tuesday, June 25, 2013 10:27 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Toad 12 - File Open dialog - no longer able to filter subset using wildcard *

RE: Toad 12 - File Open dialog - no longer able
to filter subset using wildcard *

Reply by nathan.e.schroeder

Doesn’t work for me. In my working folder, that includes files named x.sql, x-compare.sql, and other files whose names start with x, in the file/open dialog
box, I type

x*

(and get the drop-down showing all the x files) and hit Enter once, and the central window still displays all the files in the folder; and I hit Enter again,
and ALL the files disappear from that window, whether they start with X or not. All that’s still visible are the subfolders.

Nate Schroeder

US Row Crops IT Data Management Team

Monsanto Company

800 N. Lindbergh Blvd. G3WB - Saint Louis, MO - 63167

314-694-2592

Click to show quoted text

From: John Bowman [mailto:bounce-jbowman@toadworld.com]

Sent: Tuesday, June 25, 2013 9:20 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Toad 12 - File Open dialog - no longer able to filter subset using wildcard *

RE:
Toad 12 - File Open dialog - no longer able to filter subset using wildcard *

Reply by John Bowman

One other thing to note: pressing the [Enter] key appears to close the filtered drop-down box; however, it doesn’t automatically register the default [Open] action, which would execute the filter.
Pressing the [Enter] key again, however, will execute the filter.

So, if the above situation is not the case for you, try pressing the [Enter] key again and see if the filter is applied.

Let me know what you find.

Thanks!

-John

This e-mail message may contain privileged and/or confidential information, and is intended to be received only by persons entitled

to receive such information. If you have received this e-mail in error, please notify the sender immediately. Please delete it and

all attachments from any servers, hard drives or any other media. Other use of this e-mail by you is strictly prohibited.

All e-mails and attachments sent and received are subject to monitoring, reading and archival by Monsanto, including its

subsidiaries. The recipient of this e-mail is solely responsible for checking for the presence of “Viruses” or other “Malware”.

Monsanto, along with its subsidiaries, accepts no liability for any damage caused by any such code transmitted by or accompanying

this e-mail or any attachment.

The information contained in this email may be subject to the export control laws and regulations of the United States, potentially

including but not limited to the Export Administration Regulations (EAR) and sanctions regulations issued by the U.S. Department of

Treasury, Office of Foreign Asset Controls (OFAC). As a recipient of this information you are obligated to comply with all

applicable U.S. export laws and regulations.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Hi Michael, Hi all.

Uncheck “Hide extension of known files” in general windows “folder posibilities dialog” should help.

Tomas

Same for me. Filtering of file types started working when I unchecked the “Hide extension of known files” option in Windows Explorer. If this option is checked I can see files only if I select “All files (.)” in the “Files of type” combo box. This behavior started from 12.0.1.2 (the latest patch). In every version before, filtering worked regardless the “Hide extension of known files” option.

Hello,

This issue will be fixed in Toad 12.1 commercial release

Thanks,

Brad

From: vojco.kraljevski [mailto:bounce-vojcokraljevski@toadworld.com]

Sent: Wednesday, August 21, 2013 2:06 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Toad 12 - File Open dialog - no longer able to filter subset using wildcard *

RE: Toad 12 - File Open dialog - no longer able
to filter subset using wildcard *

Reply by vojco.kraljevski

Same for me. Filtering of file types started working when I unchecked the “Hide extension of known files” option in Windows Explorer. If this option is checked I can see files only if I select
“All files (.)” in the “Files of type” combo box. This behavior started from 12.0.1.2 (the latest patch). In every version before, filtering worked regardless the “Hide extension of known files” option.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.