Toad World® Forums

Wildcard not working in File Open dialog

TFOEE 12.0 (working to get upgraded to 12.1, so I apologize if this is already resolved):

The “open file” dialog does not allow me to limit displayed files using wildcard *. So I have a directory, want to see all .sql files related to budgets, I’d type budget.sql in the filename, and press enter. In standard-Windows boxes, this action would update displayed files to only show, e.g. “create_budget_table.sql”. But in Toad’s open-file, when I press Enter, the dialog box refreshes to empty list (despite numerous files matching the wildcard pattern).

Hey Kevin,

I’m not able to reproduce your exact issue in Toad 12.0. You may need to press “Enter” twice, as there was an issue with the first “Enter” closing the drop-down but not registering the change in the explorer list in 12.0.0. This issue was fixed for the Toad 12.0.1 patch.

However, there was a similar bug to the one you’re reporting in Toad 12.0 and 12.1 that happened when the “All Files (.)” filter was selected. It has been fixed in the current beta version. However, to get around this issue in Toad 12, you can do the following:

  1.  Make sure you’re on the current patch of Toad 12.0.1. 
    
  2.  Go into Files -> General page of Toad’s options
    
  3.  Add a custom filter (if one doesn’t already exist) for the file types you typically work with, as in the following example (for this example, I’ve added the “**” characters to the “Type” description so it appears first in the drop-down list):
    

  1.  Select the file type, if it’s not already selected:
    

  1.  Add your wildcard search and press “Enter”
    

I hope that helps with your issue until you’re able to upgrade to the current version.

-John

From: KevinAK [mailto:bounce-KevinAK@toadworld.com]
Sent: Friday, April 04, 2014 11:20 AM
To: toadoracle@toadworld.com
Subject: [Toad for Oracle - Discussion Forum] Wildcard not working in File Open dialog

Wildcard not working in File Open dialog

Thread created by KevinAK

TFOEE 12.0 (working to get upgraded to 12.1, so I apologize if this is already resolved):

The "open file" dialog does not allow me to limit displayed files using wildcard *. So I have a directory, want to see all .sql files related to budgets, I'd type budget.sql in the filename, and press enter. In standard-Windows boxes, this action would update displayed files to only show, e.g. "create_budget_table.sql". But in Toad's open-file, when I press Enter, the dialog box refreshes to empty list (despite numerous files matching the wildcard pattern).

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from Toad for Oracle - General notifications altogether.
Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.

I am also not able to reproduce in 12.1.1.1 (Toad for Oracle Pro). When I type *.dkd it changes the filter to show custom filter and nothing shown because I don’t have that extension in that folder. If I then type .sql or c.sql, it will either show all files that match the predefined filter that contains that extension or the ones starting with c respectively. Sounds like you need to break out extensions into separate associations as alluded to above.