Toad World® Forums

TOAD 14.0.75 does not trigger explain plan for DDL

Hi All,

I have noticed that new Toad 14 does not trigger explain plan for DDL statements (CREATE TABLE, CREATE INDEX and etc). It used to work before and it is supposed to work. Is it an "improvement" of new version or I am doing something wrong?

Thanks,
Rusty

Hi Rusty,

Oracle can only create explain plans for SELECT, INSERT, DELETE, UPDATE, and MERGE statements.

Maybe some other database can show plans for DDL? I'm not sure what you are thinking of. If you're certain that and older version of Toad did something that 14.0 does not, can you post a screen shot?

-John

Hi John, Thanks for reply. Oracle definitely supports explain plan for DDLs. And it worked fine in Toad 12. Here are few screenshots made in Toad 12:



image

Well, I sit corrected.

Which version of Oracle are you connected to? When I try with Oracle 12, I get something a little different (CTAS just looks like a select)

Anyway...ok. And I actually remember breaking that, thinking "why are we attempting EP for DDL". I'll fix it.

Great, Thanks! I am on 11g now, but it should not matter. I tried to execute exmplan plan for explicitly and it added some records to the plan table. So problem is that Toad simply stopped even execute it on ctrl+E. The only small caveat I can recall is to be able to explain DDL I had to select whole statement. For SQL it was enough to place a cursor on it. It would be nice if DDLs would work the same way.

ah! I see that now when I select the whole statement.

Ok, we'll have it fixed for 14.2 beta within a week or two.

By the way, I really recommend that you get off of version 14.0 and use 14.1 instead. 14.0 had some problems with locking up.

Update: According to Oracle documentation, the types of statements that can be Explained are:
SELECT, INSERT, UPDATE, DELETE, MERGE, CREATE TABLE, CREATE INDEX, and ALTER INDEX REBUILD