Toad World® Forums

Toad 14 support for Oracle RAC using DB 19?

We are working on an infrastructure upgrade project. We're moving from a single 12c database to a dual database RAV configuration using DB version 19. I was given the following TNS Name entry from the DBA. Hostname has been replaced for redaction to foo.bar.com, the hostname of the load balancer. Toad does not even see this entry when trying to select it when logging in. Version 19 client is installed and works with SQL Plus, however SQL Plus doesn't connect to this TNS Entry either. I have a ticket open with Oracle Support as well.

  1. Does Toad 14 support Oracle Client and DB 19?
  2. Does Toad 14 support Oracle RAC configuration? If so - is the any other special settings that need to be done in the listener or in Toad to allow this failover to happen?

Any help would be greatly appreciated!

PROD =
(DESCRIPTION =
(ADDRESS_LIST =
(FAILOVER = on)
(LOAD_BALANCE = on)
(ADDRESS = (PROTOCOL = TCP)(HOST = foo.bar.com)(PORT = 1521))
)
(CONNECT_DATA =
(SERVICE_NAME = PROD)
(FAILOVER_MODE =
(METHOD = BASIC)
(TYPE = SELECT)
(RETRIES = 18)
(DELAY = 1)
)
)
)

Toad most definitely supports RAC. There are no special settings that you need to make.

I pasted your PROD entry in my tnsnames.ora and I see it in the dropdown on the login window.

If Toad was running when you did that, put focus in the Database dropdown of the login window, and hit F5 to refresh it, then look again. If you still don't see anything, I suspect a syntax error somewhere in your tnsnames.ora file above the PROD entry. You could try moving the PROD entry to the top of the file, at least temporarily, to confirm.

Funny! Doesn't show on my end:image

Even more interesting, it shows up in the TNS Names editor perfectly as I pasted it.
Its only allowing one image for me to paste - see my next post for the TNS Names editor screen shot.
Any ideas?

There is something about your formatting or whitespace that's making it not work.

The first time I tried it, I copied the whitespace-stripped text from that our forum did to your post. That worked fine.

Just now, I grabbed the text that you actually pasted (as an admin, I have access to that), and I can reproduce the problem.

I'm trying to narrow down the exact thing that is tripping it up.

Ah-hah!

The problem is the leading space before PROD. Take that out.

Looks like this is still a problem in the most recent version of Toad. I will fix it for 15.1.

You're awesome John! That did the trick! The leading space on the first line!
Thanks for working this in to the next revision!

1 Like

I'm still not able to connect now - with the enhanced TNS Names file.

DBA provided this file from the RAC instance and they are able to connect.

The Oracle client makes the connection, not Toad. Can you connect with SQL Plus?

The error message makes it sound like the Oracle client doesn't see the database server.

Just found out the vpn connectivity between client and server was down - it was brought back up and it works now. Thanks!

1 Like

FYI: In testing this, I discovered that the neither the 12cR2 nor the 18c client will connect to a TNSNames entry with a space before it.

Maybe the best change for Toad is to detect and alert the user if there are tnsnames entries with leading spaces.

(Edited)

1 Like