Toad - sFTP issue

I just upgraded from to and finding an issues using secure FTP with a Private Key File. Pointing to the exact same file in the new version, getting:
TCP connection opened. Waiting for SSH authentication...
TCP Connection closed
Logon to ########:22 as XXXXX failed: Authentication (public key) failure.

Same file works in previous version. Anybody else noticing that issue? Thanks

Funny that you bring this up... because just yesterday I destroyed our FTP testing server accidentally. :smile: I have it on my list to recreate tomorrow and then we can run some tests.

1 Like

Exact same thing happened to me! I thought I was going crazy, glad to know I'm not the only one who experienced this. Should I submit a support ticket?

I downloaded Rebex Tiny SFTP Server and configured it with a private key file. I'm able to upload and download files to it with Toad 15.1.

I guess I need more info on your configuration.

@jim.schmitz @sam.mcknight
I am able now to reproduce this...sort of.
I set up OpenSSH on Oracle Linux 8.4 following these steps (it was mostly set up out of the box...who knew?)
Toad 15.1 gives the error message you describe above, but Toad 15.0 gives an "unsupported protocol" message.
But I can connect using MobaXTerm to that server (using the private key file)
And I can also connect using Toad w/o the private key file (using username and password)
I'm working with a 3rd party vendor of our network protocol components to try to get it figured out.

If you can tell me anything about your FTP server versions and encryption algorithms, that would be helpful.

Here is the info on our server. We are in OCI Cloud if that makes a difference, this same sever worked fine in previous version of TOAD using sFTP

sftp> version
SFTP protocol version 3
sftp> exit

$ cat /etc/os-release

NAME="Oracle Linux Server"
PRETTY_NAME="Oracle Linux Server 7.9"


1 Like

I think I have this fixed for version 16.1 beta, which will be available soon (probably monday). Version 16.0 is planned for release today.

I still don't have a scenario where 15.0 works and 15.1 does not, but I found some problems in the code that I think prevented 15.1 (and 16.0) from working.

I set up SFTP on an Oracle Linux 7.5 server (it's the closest I have to 7.9) and can connect to it with what will become the 16.1 beta, but not 16.0 or 15.1 or 15.0. I am getting "unsupported key algorithm" on 15.0, "logon failed: Authentication (public key) failure" on 15.1 and 16.0.

1 Like

@jim.schmitz @sam.mcknight

Toad Beta 16.1 is now available and I believe I have this fixed. You'll have to install version 16.0 and run it at least once if you haven't done that yet before the beta will run.

Please give it a try and let me know.


I tried it on Beta 16.1 and it appears to be working now, thanks!

1 Like