Toad 17 - Unified Auditing Policies bug + suggestions


There appears to be a bug related to enabling Unified Auditing policies via the schema browser.

To replicate the problem:

a) Create a test policy but do not enable it

b) Navigate to Schema Browser > Unified Audit Policies, click on the policy and click the Edit icon (or right-click > Alter)

c) In the Enablement field, choose Enabled for all Users and click OK. A message appears: No changes have been made

Also, a couple of suggested features that would be useful in the Unified Auditing Policies browser:

  • An additional column showing whether a policy is enabled or not
  • A shortcut button and/or right-click menu option to enable/disable a policy

Hi Ian,

Thanks for reporting this.

Re: "No changes have been made" - I can reproduce that and have logged it to be fixed for the first version after 17.1.

Re: Suggestions - good ideas, thanks. I'll add that.


I forgot to mention -

if it helps, you can at least filter by "Enabled policies only"

Thanks for the tip John