Toad World® Forums

Toad 3.0.1 - Option to not Use Fully Qualified Obj Names not working

I have uncheckmarked the “Use Fully Qualified Object Names” option under Tools > Options > Database > Query Builder. But the query builder continues to fully qualify the table object with the schema name. I did a search of the forum and didn’t find any immediate hits for existing tickets.

This is particularly painful when using ODBC drivers which are not designed to accept the schema as part of the query string: the query fails. As a result, I have to continually hand-edit queries built with the query builder. I’d like to know if this is truly a bug and if/when it will be fixed.

I tested with an ODBC and Oracle connections; the schema string is added regardless of the state of the “Use Fully Qualified Object Names” checkbox.

I am using Toad 3.0.1.

Thanks!

Wow, you are right. It is not working. We will fix that. CR95430
Thanks for pointing this out.

Debbie

Thanks for the quick response; looking forward to the fix.