Tools / Options Database QueryBuilder Disable Fully Qualified Object Names


As I’m writing queries that have to run on different DB’s I do not want the objects to be qualified with DB or Schema.

I Unchecked the box in the options screen, but the objects are still qualified. This was the same in TFDA, and was suposed to be solved in this release.

Is there a workaround (or a new version planned)? It is annoying because when I forget to remove the qualification the query (or view of function) does not work on other DB’s

BvdP (Netherlands)

What server do you use? I assume that it’s SQL Server.
I checked the option and confirm that it does not work for SQL Server. It works for Oracle but not for SQL Server.
I created CR #104639 to track the issue.
Thank you for reporting it.